Habmin - loading

As mentioned, habmin just sits there saying “loading…” and never does.

I’ve tried uninstalling habmin from PaperUI, then rebooting, reinstalling but same issue. No idea where to start to diagnose this.

Works fine here with snapshot #975 and always did work with previous builds

Are you trying to start HABmin through remote connection via myopenhab? I’ve read that there are issues in this case … on local network it should start, though

No, running locally.

I’m on OH2.1, HABmin binding is 2.1 as well.

I can leave it indefinitely and it never loads.

Actually it is a UI User Interface, not a binding.
Maybe you should check via karaf console if you have more than one HABmin loading …

212 | Active | 80 | | HABmin User Interface

Sorry, yes I did mean a UI.

bundle:list | grep HABmin*

Edit: and make sure it says “Active”

223 | Active | 80 | 2.1.0 | HABmin User Interface

Were do I get 2.2.0… version from? Do you have a link? And where do I place the .jar file being that I originally added the HABmin UI from PaperUI?

You don’t place any .jar files … just install HABmin from PaperUI.

If you want 2.2.0 you need to upgrade your runtime from stable/release to snapshot:


Ok I’ll give that a go. Thanks for your help sihui

1 Like

Same issue. Just sits there saying loading. Must be some other underlying issue.

That is bad … sorry, no more ideas.

Are there any habmin log files? If so, do you know where they are located? (or how to enable debugging for them?)

You can debug HABmin according to the developer by using the browsers debugger (for example chrome).

In that thread the solution was to simply delete the browsers cache to make HABmin work …


I just tried Firefox instead of Chrome, BOOM! Straight in. Lol, always the simple things.

Thanks sihui yet again!!!

1 Like

Strange, I’m using it with Chrome …:sunglasses:

I’ll clear my cache - just did a quick and simple test. Who would have thought…!