Habmin not working

I have openhab 1.8.2 running on a Intel NUC.
Before this setup it ran on a RaspBerry, but my SD cards got damaged frequently.
Openhab is running fine but Habmin is not.
It loads the page but Openhab status is offline.
I see the following in the logfile: - - [02/jun/2016:11:54:06 +0000] “GET /webapps/habmin/resources/ext-theme-classic/images/grid/loading.gif HTTP/1.1” 200 771 - - [02/jun/2016:11:54:06 +0000] “GET /services/habmin/config/bindings?_dc=1464868312422 HTTP/1.1” 404 1470 - - [02/jun/2016:11:54:06 +0000] “GET /services/habmin/bundle?_dc=1464868312427 HTTP/1.1” 404 1443 - - [02/jun/2016:11:54:06 +0000] “GET /services/habmin/config/items?_dc=1464868312414 HTTP/1.1” 404 1461 - - [02/jun/2016:11:55:21 +0000] “GET /services/habmin/config/rules/model/list?_dc=1464868387397 HTTP/1.1” 404 1494 - - [02/jun/2016:11:55:22 +0000] “GET /services/habmin/config/designer?_dc=1464868388497 HTTP/1.1” 404 1470 - - [02/jun/2016:11:55:22 +0000] “GET /services/habmin/config/persistence/services?_dc=1464868388443 HTTP/1.1” 404 1506

I have the org.openhab.io.habmin-1.7.0-SNAPSHOT.jar and org.openhab.binding.zwave-1.8.0-SNAPSHOT.jar in the /usr/share/openhab/addons directory.
openhab was installed using apt-get.

Can someone point me in the right direction?


Do you have the zwave binding installed as well?

I tried with and without the zwave binding.
Both are not working.
Ther are a lot of 404 messages in the log:
“GET /services/habmin/config/icons?_dc=1464929709173 HTTP/1.1” 404 1461

there is no /services dir on my system.


Well, it will only work with the zwave binding, so no point trying without. You might also need the serial driver as well since that’s a dependancy on zwave.

I’m pretty sure that HABmin is not running - probably due to missing dependancies, but I can’t be sure of course.

This is a REST URL, so it’s not related to directories in any way.

I get the same result intermittently - habmin shows offline, and 404 errors on any request to the habmin services URLs. Sometimes restarting OpenHab resolves it for a while, sometimes it takes two restarts.
The zwave binding appears to be working - it logs messages when a device changes state (I’m just starting with zwave, so I only have one device to test with right now).

-rw-r--r-- 1 root openhab 1237582 Nov  5 22:45 addons/org.openhab.binding.zwave-1.8.3.jar
-rw-r--r-- 1 root openhab 1134175 Nov  5 23:21 addons/org.openhab.io.habmin-1.7.0-SNAPSHOT.jar

I’ve noticed twice that the habmin jar goes into a weird state and stays that way until openhab has been shut down for a minute or two:
-??? ? ? ? ? ? org.openhab.io.habmin-1.7.0-SNAPSHOT.jar

I’ve never seen this before – especially when logged in as root