Habmin2 : 404 ..update ... OH2 : NamespaceException

Hi, in my testings of openhab2 and habmin2, I could NOT, under habmin2, create an item and link it to the channel of my zwave device (after having unactivated the auto-creation under paper-ui).
=> habmin2 systematically throws a 404 error - nothing in log (restarting the system does not better)

habmin2 version : org.openhab.ui.habmin_2.0.0.SNAPSHOT-0.1.6.jar
openhab2 version : openhab-online-2.0.0-SNAPSHOT.zip (may 28)

==> is this an habmin2 known issue ?

So I tried to DOWNGRADE habmin2 to the release 0.1.5 … bad idea.
then I systematically get those logs, and habmin doesn’t work at all :

2016-06-04 09:52:31.767 [ERROR] [org.openhab.ui.habmin ] - [org.openhab.ui.habmin.designer(170)] bind method [setItemRegistry] not found; Component will fail
2016-06-04 09:52:31.775 [ERROR] [org.openhab.ui.habmin ] - [org.openhab.ui.habmin.designer(170)] bind method [setItemRegistry] not found
2016-06-04 09:52:31.851 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
2016-06-04 09:52:32.023 [ERROR] [ui.habmin.internal.servlet.HABminApp] - Error during HABmin servlet startup
org.osgi.service.http.NamespaceException: alias: ‘/habmin’ is already in use in this or another context
at org.ops4j.pax.web.service.spi.model.ServerModel.addServletModel(ServerModel.java:130)

(I might have had a brief moment the 2 jars in the addons folder. But booting with either one no throws this message)

Only thing I could do to get it working again is … deleting userdata folder . Which is highly destructive. Is there another way to upgrade addons ? Do we have ANY way to interfere with OH2’s cache (with karaf command line that I don’t master ?) to clear things properly ?

by the way … I cannot create an item on my device’s channel under habmin2 0.1.5 too : I still get http 404.

is there a way to set habmin2 to debug like bindings ?

Pease can you describe what you are doing and what item name you provided.

No - it should work, so probably you are doing something that is either wrong, or something that is not expected at least.

Since OH2/ESH are in active development, it often means that you can’t change back to older versions where we’re making use of new features in the framework.

Hi @chris. I only clicked on the button “create item and link to channel”, and clicked “save” with default name suggested by habmin2 (custom name already tested and non working)

I have this in my logs, maybe is this the root cause ?
2016-06-04 10:10:28.590 [ERROR] [org.openhab.ui.habmin ] - [org.openhab.ui.habmin.designer(170)] bind method [setItemRegistry] not found; Component will fail
2016-06-04 10:10:28.592 [ERROR] [org.openhab.ui.habmin ] - [org.openhab.ui.habmin.designer(170)] bind method [setItemRegistry] not found

this happens after clicking “save” :

Ok - the problem is the name of the item - the “-” isn’t allowed.

I’ll open an issue to remind myself about this and try and fix it in the next day or two.

And for reference -:

aw! You got it. Then it was a new bug indeed :slight_smile: