Habmin2 no data appearing on chart

I am a total newbie and just installed openhab2 and habmin on a linux box with a zwave stick.

I am trying to create a chart in habmin2. I have apt-get installed 2.0.0b3 of openhab and the working dir jar for habmin. I was able to set up my ST814 sensor in the paperui (but not edit the parameter values, they would only allow me to select “disabled” for everything), then configure it to send updates every minute in habmin. I can now see up-to-date sensor data in the PaperUI control section.
I also added the rrd4j persistence extension.
I tried adding a chart in habmin, which kind of seems to work by just selecting “chart editor”, then the sensor (eg temperature 1) and then saving the chart by name “c1”. I left everything else as default.
I can see a file zwave_device_9b27f636_node2_sensor_temperature.rrd being created, I can see a file chart.xml being created and I can see entries like “2016-06-09 11:30:06.761 [INFO ] [marthome.event.ItemStateChangedEvent] - zwave_device_9b27f636_node2_sensor_temperature changed from 22.6 to 22.5” in the openhab log. What could be the problem? Are there any non-default settings I have to set to actually see something?

btw, in the chrome debug console I dont see any exceptions.

also, I tried to create a dashboard with a gauge for my temperature sensor, but this part is probably just not there yet, right?


PS: I am a dev, but dont have any dev stuff on that linux box as its my router and nas

You should set the default persistence that HABmin uses in the HABmin user settings. If you don’t do this, it might not download the data.

Also, have you tested (somehow) that the persistence is actually storing data?

I tried setting default persistence, but it somehow does not store the setting (or the ui does not show it?). Also, the rrd file does not seem to get modified after creation. it always gets created when I select the sensor as a chart component but is then left alone. is there some place on disk I could look for the setting to be stored? Or some place where I could set the rrd settings?

this is the chart.xml file for now:
<?xml version="1.0" ?><charts><entries><chart><id>1</id><name>c1</name><period>86400</period><legend>true</legend><items><item><item>zwave_device_9b27f636_node2_sensor_temperature</item><axis>left</axis><label>Sensor (temperature)</label></item></items><axis><axis><position>left</position></axis><axis><position>right</position></axis></axis></chart></entries></charts>

If the rrd database files aren’t being updated then it seems likely that data isn’t being stored?

You are right that the default persistence box in Habmin is not set properly - this is fixed already but even though it doesn’t show in the box, it still gets set so is important.

Yes, it could very well be that data is not stored at all. Looking at the rrd file via the rrdinspector I can see no archive data. But how could I fix that? I tried deleting and recreating the chart many times. Do I have to set one of the values to some kind of period? There are two values that could matter maybe, Repeat Time and Default Period, so I set the Repeat Time to 1 just to try, but nothing changes.

The persistence must be configured separately using the .persist files. This can not be done through HABmin. Check out the openHAB wiki for the persistence configuration.

Thanks a lot for the quick replies. I now installed a postgresql persistence (and my.openhab.org for good measure) which seems to store the data nicely (I can see it there via the psql commandline). I also set the default storage in preferences to jdbc, and clicked on “jdbc” before saving the chart. I still dont see a chart or something though. Should I be seeing some lines before hitting the save button already?

Ok, after waiting for a night and now trying again, it seems to show something. The parameters I change when saving (like axis) are not honored, but I can see several different sensors on the same chart, even when its kind of impossible to look at temperature and humidity on the same graph because of different scales. But this is already much nicer than before. Thanks for the tips.

What do you mean? Please feel free to open an issue if something isn’t saving properly.