HABPanel Factory Settings

Hi all,

How can I restore HABPanel Demo Example to factory defaults?
Is demo.json somewhere on GitHub?

If so you would find it here:

Could you point me directly where to find JSON config to restore HabPanel to its initial state?

If you just misconfigured your HABPanel and want to reset it, delete your browser cache and all settings should be gone.
If you are using server side storage, delete the file /userdata/config/org/openhab/habpanel.config and you will need to start from scratch.
If you messed up some other files I have no idea how to reset, sorry.
I guess uninstalling the binding and reinstalling it should do it.

none of this methods had no expected result.

Any ideas else?

Currently I don’t have any HABPAnel UI,
BUT I need to restore DEmo setup.

No, sorry.
If you did save your config to the openHAB server via HABPanels “Advanced settings”, you could load them again from another computer. That is all I can suggest.

If you just want to play around with it you could use the openHAB demo server:

http://demo.openhab.org:8080/start/index

Is there something wrong with my network or this server almost always down?

image

You may check at:

http://status.openhab.org/

I can mark your post as “answer”, but actually there is no appropriate answer,
as soon as there is no build-in possibility to revert factory preset for OpenHAB. by single mouse click.

Feel free to open a feature request.

How to play around?
There is no button to download source JSON for demo server habpanel !