Habpanel handshake failure and no “things”

OpenHAB 2.3.0 running on Synology
I’m having trouble loading widgets in the habpanel. When trying to import it gives me a handshake failure… ?

Also when trying a simple dummy widget I have no items to control - I have bindings and things found in paper UI. Phones, tablets, receiver, hue bulbs, squeezebox all shows up and list in paper UI…

Handshake failure.

No things listed

Following error when checking


{“error”:{“message”:“Received fatal alert: handshake_failure”,“http-code”:500,“exception”:{“class”:“javax.net.ssl.SSLHandshakeException”,“message”:“Received fatal alert: handshake_failure”,“localized-message”:“Received fatal alert: handshake_failure”,“cause”:“javax.net.ssl.SSLHandshakeException”}}}

Had this problem and solved it by installing a Let’s Encrypt free certificate to replace the self generated Synology certificate, using my synology.me DDNS service.


I have installed the LE cert based on my synology.me ddns address in control panel. Then restarted OH.

I still get the handshake error. Are there any there steps? Cheers