HABPanel has no icon in top corner to configure

Hi, I’m new to openHAB and are just looking at all of the functions. I have managed to get a switch configured which is working perfect in Basic UI. So far so good.

I installed HABPanel UI via binding in PAPER UI. When I navigate to HABPanel I just get a black page with no icon in the top right corner. I have tried this is all browsers and its the same in all of them. I have uninstalled and reinstalled both openHAB and HABPanel. Checked permissions and owner of all openHAB folder and files in all locations openHAB is located in.

As everything so far as been exactly as in tutorials, I can only assume I’m doing something wrong. Can someone point me in the right direction please.

OS - Xbuntu 16.04


I may be wrong but have you disabled the “lock Editing” flag so that you can modify Panels?

I don’t use the paper ui but via habmin I can go to Configuration -> Services -> UI and select HABPanel
There are then two options “Lock Editing” which needs to be false if you want to modify panels and “Initial Panel Configuration” in HABmin it shows explanations for each.



Thanks for the reply. I have tried it with the lock on and off but still the same no icon - just black screen.

I have just loaded HADmin via paper ui. When I navigated to it I got a Error 500. Then I got a server off line popup message. I found the configuration icon in HADmin but this then brings a download icon. Is there a config fill that I’ve missed. I’m just playing at the moment, but from what I have read, it would seem HADPanel is what I’m looking for as a interface. I’m don’t mind how I configure it. But got to play before I finally decide


Hi John,

I will see if I can fire up a vm running the same Xbuntu version and install OH to see if I can help resolve this.

To help can you confirm if you installed OH manually or via the repository?



So I have Just

  • installed Xbuntu 16.04 in a Virtualbox VM
  • Installed all patches
  • Added openhab2 apt repository main stable
  • Added Zulu repository main stable
  • Installed Zulu-8
  • Installed openhab2.2 and addons
  • Started OH2.2
  • Opened URL http://localhost:8080/
  • Chose “Standard Setup”
  • Accessed HABPanel and the “Edit Dashboard” icon appears without issue.

Sorry but not sure whats happening with your configuration as I cant seem to replicate the problem.

Perhaps one of the long time users of Oh/HABPanel may have some better ideas :frowning:

At least this now gives me a playground for testing even if it doesn’t actually control any devices.


Hi Kevin,

Sorry for the delay in getting back to you.

Thanks for doing that.

Looking at what/how you have done it, apart from the VM its exactly what I did. As I said originally, got everything up a running (only a single switch ) very easily. Only started to give me an issue from when I installed HABpanel. Its like a files got the wrong permissions or owner but nothing pointing me to it, in the logs. I was sure last night when I looked at the log the server was listening on a different IP address. But now I can’t find any reference to that. Think I might been getting work and home project merging in my mind or I’ve just dreamed it.:grinning: I have another box which is currently drive less. I will put a SSD in it and build an identical unit from scratch. Should be able to easily see what the difference / problem is then.

Will let you know what I find


Got it to work now. Looks like the problem was with java. Put a new hardrive into another ultra Compact box and loaded everything from scratch. But had the same problem with this second unit - black screen in HABpanel with no configure icon. So on the second unit I changed to openjdk-8-jdk-headless. After reboot the config icon is now there. So just to prove the point, I did the same with the 1st unit and exactly the same after reboot. Only difference between the devices is the size of the SSD. The first unit has 240GB and the second unit has 120Gb. Everything else is the same including the make of the SSD’s Its most likely something to do with the hardware combination.
Thanks for you help.