Habpanel home screen app unresposive

Tags: #<Tag:0x00007fc3f1583a10>

Hi,

I have setup habpanel on a nexus 10 tablet, as a home screen app (ie it is what comes up by default when the user opens the tablet).
It works OK, but when a tablet is inactive for a few hours, it becomes unresponsive (sometimes it even crash) for a few minutes.

Any suggestion how to fix it?

Thanks

I’ve seen something similar on my Android phone (Pixel XL). I added HABPanel as a bookmark on my home screen. When I first bring it up, it works great. I really like how it behaves like a native app. The problem occurs when I leave the app for an hour or so. When I go back to the app, it is unresponsive and doesn’t show the current status of buttons/switches/widgets/etc. I kill the app (pull up recent app list and swipe right) and restart HABPanel. It then functions properly again.

I’m also interested in any suggestions to fix this. Thanks!

I believe a similar bug on Android has been reported, if the device goes to sleep, the dashboards are not updated after waking up. I need to have a look…

FYI I have also seen this same problem on the iPad, running Safari.

Has this problem been addressed?
I have the same problem and right now Habpanel is not usable for me.
Habpanel on my wallmounted tablet (android 5) is unresponsive after a while, same applies to iPad.

cheers,
stefan

Same issue here ! …

I use the transparent skin with a wall paper is there some skin that are better for performance ?

If I setup an auto refresh every 5 min could it be ok ?

I’m using default skin with just 4 simple switches (testing)… so i guess it’s not the skin…

wow … :confused:

i’m gonna try to refresh every 5 min to see if it help !

To people using Android/Chrome, when this happens, I would appreciate it if someone could follow these instructions:

in short:

  1. Enable remote debugging on the device

To access these settings, open the Developer options in the system Settings. On Android 4.2 and higher, the Developer options screen is hidden by default. To make it visible, go to Settings > About phone and tap Build number seven times. Return to the previous screen to find Developer options at the bottom.

  1. Plug the tablet to a computer

  2. Open Chrome on the computer

  3. Hit F12

  4. Use the ‘…’ menu and choose More tools > Remote devices

  5. Click on your device on the left side then on the ‘Inspect’ button of the line correponding to your non-responsive HABPanel

  6. Report back errors in the console of the new window (this is a remote debugger attached to your device)

Thanks!

I “fix the issue” withe 2 “solutions” ( I test both on different tablet )

First : Switch dashboard with item value. So i switch to the home screen with an openhab rule that send value every 5 minute then send empty value.

Pro : Built in and it work Con: it’s a crappy solution !

Second : put the habpanel in a ifram then ask html to refresh page every 5 minutes

Pro : full control of the html can add everything i want like a logo for the webapp. Con : need a web server, every 5 minute my tablet goes white because it refresh and it’s a crapy solution too

I know I know it’s just a band aid on the issue BUT !! my GirlFriend was mad that everything stop working ( I just migrate to Habpanel I used to have a web interface that look pretty much the same as Habpanel but with less possibility )

I managed to install everything so that i get an console output.
Now i have to wait for the tab to become unresponsive…
One first warning message i found was:

Handling of ‘touchmove’ input event was delayed for 2147483647 ms due to main thread being busy. Consider marking event handler as ‘passive’ to make the page more responsive. vendor.js

Not sure if that’s already relevant though :wink:

Ok, i got the logs… thank you for investigating :wink:
Another thing that seems weird is that the status of e.g. a switch is set from ON to OFF and then again from OFF to OFF…

Here are the warnings and errors as screenshoits followed by the log as a pdf.

… and here the (long) log as a PDF:
192.168.178.48-1483566187415.pdf (57.3 KB)

1 Like

Tried Habpanel in Firefox on my tablet and received following popup error message after a while:

Warning: Script not answering
A script on this page is either busy or not responding… […] …/habpanel/vendor/vendor.js:14

Edit:
another Script warning, this time vendor.js:160

1 Like

Interesting and very strange. Normally it enters this piece of code only if the state actually changes - I’m wondering if there could maybe be multiple concurrent EventSources at some point.

You seem to have network issues in the errors screenshot, so you can’t receive updates while it’s in this state, not much we can do. However, it should recover nicely and start listening to updates again.
I have a few optimizations in mind already for this part.

The warnings should be unimportant, but the 2147483647 ms delay here is quite alaming :slight_smile: This has to be wrong…

Handling of ‘touchmove’ input event was delayed for 2147483647 ms

Thanks for the PDF as well, not much to see at first sight apart from what’s in the screenshots but there is Atmosphere-related stuff which is normally for OH 1.8 only!

I’ll have more next week.

1 Like

Hey, any solutions for this topic?
I also have this problem. Have to close the “app” and open it again to control my house.

Hi.
The same problem here. Any new solutions for the problem?
Thanks,
Markus

same problem here!

Same problem here too. Did this ever get resolved?

i did the remote debugging but no errors.
just the inactivity screen of the tablet device

I’ve been struggling with this since I setup OH and 3 Android tablets on my walls since June. After changing all kinds of settings on the tablets; I finally realized what is going on.

The tablet is going to sleep and loosing it’s “refresh” settings within Habpanel. I have the weather up as my main screen with animated icons which is how I know Habpanel hasn’t refreshed because the icons stop moving.

Here’s what I did last night which is the first full night ever that Habpanel was still working in the morning.

Enable developer options and debugging
· Open the Settings app.
· (Only on Android 8.0 or higher) Select System.
· Scroll to the bottom and select About.
· Scroll to the bottom and tap Build number 7 times.
· Return to the previous screen to find Developer options near the bottom.

How do I Stop My Android Tablet from Sleeping?

  • In Settings if you scroll down towards the bottom directly under “Accessibility” you should see a “Developer Options” section
  • Inside this there is a Setting called “Stay Awake”.
  • Enable this and your tablet will no longer fall asleep on you :wink:

The negative side to this is the screen doesn’t ever go black but it does dim after a while.

Best, Jay