HABPanel missing, stuck on installing with reinstall

So I migrated most of my configuration from OH2 to OH3.1. I generally use HABPanel for my daily interactions with the devices since I haven’t figured out the newer floor plans and stuff in the new interface.

Some background:
I had some problems with MQTT disconnecting and reconnecting which I traced to the system broker having a config. I purged the cache and temp folder then brought OH back online which fixed things… sort of.

After purging /var/lib/openhab/cache and /var/lib/openhab/tmp I couldn’t pull up HABPanel. Instead I get a Sorry resource not found message along with the following info.

Debug information

    Url: /habpanel/index.html
    Path: /habpanel/index.html
    Hash:
    Params:
    Query:
    Route: (.*)

So I went to Settings > User Interfaces to see what was going on. It said “No user interfaces installed yet”. I clicked on Add then on HABPanel to get it to install. It just sits there with with installing, but never finishes. If I reload the user interfaces options it still says “No user interfaces installed yet”. Clicking add again still has HABPanel but this time it doesn’t say installing.

This is what it looked like when I clicked HABPanel to reinstall.

I looked through openhab.log and it doesn’t mention HABPanel except for it stopping yesterday.

2021-09-27 22:52:48.792 [INFO ] [ab.ui.habpanel.internal.HABPanelTile] - Started HABPanel at /habpanel
2021-09-27 22:53:46.573 [INFO ] [ab.ui.habpanel.internal.HABPanelTile] - Stopped HABPanel

So now I’m out of ideas of what to try next. I’m guessing it is in some sort of inconsistent state where it is installed but missing something that makes it think it is installed.

  • Obligatory Platform information:
    • Hardware: Raspberry Pi 3 B+
    • OS: Raspbian Buster
    • Java Runtime Environment: OpenJDK Runtime Environment Zulu11.50+19-CA (build 11.0.12+7-LTS)
    • openHAB version: 3.1.0

Ok, I got HABPanel reinstalled. I ran feature:start openhab-ui-habpanel which got me a blank panel.

I have a backup file from OH2, before I moved to OH3. Which one of the backup files will get my HABPanel config back?

I got it working again. I had to set up a parallel installation of OH2 on another Raspberry Pi with the backup restored to it. I copied the JSON data from the settings of the OH2 installation over to the OH3 installation.

habpanel-settings

Honestly this is the easiest solution. You should mark it as solved as the answer for others searching for same problem.

I have the same issue. I even tried installing the toolbox first, but it didn’t work. Did you happen to resolve this? Please reply if anyone have suggestion.