HabPanel not updating

I have a wall mounted iPad 2 using habpanel to control my lights which are a mixture of technologies (insteon, hue, tp-link, wemo, wifi/magichome). When anything has a state change outside if openhab (i.e. via Alexa) the display does not update. Openhab itself understands the new state, but it’s not showing up in HabPanel. If I reload the browser window it shows the new state, but I’d like it to update automatically. Any thoughts?

Bruce

Does it work in a regular browser on a computer? Open the dev tools console in a Chrome browser
( Command+Option+J on Mac, Control+Shift+J on PC)
and check whether you see “Updating item X state from Y to Z)” in the Console

OK - on chrome on a Windows 10 PC, it updates just fine. It must be something about the full screen browser I’m using on the iPad (chrome doesn’t support full screen). Any recommendations on a full screen iOS browser that will update properly?

it’s not a chrome problem. I use Safari, on ipad2 and i have same problem

Hi,
have you managed to find the solution ? Exact same problem, Galaxy tab 2 with habpanel on and it’s not updating when item state changes, I have to manually refresh to see the change !

i have the same problem on Chrome and Fully kiosk too,I have to manually refresh to see the change too.

I’m also having such issues. Mainly if the tablet is going to sleep. (I’ve an automation which wakes up the tablet on movement). Chrome update to the latest version helped a bit, but it is still 50-50.

my problem is with group switches at habpanel.When i use the group switch to turn on all the items in that group the items turn on but i dont see at log a [GroupItemStateChangedEvent] that group has changed to ON so the switch at habpanel does not update status and remain to OFF.I have to reload the page to see it to ON.The other way around ,turning from ON to OFF ,works just fine everytime.My groups are set like this:

Group:Switch:OR(ON,OFF)  livLights       "livLights" ( All_Lights )

if i use NOR(ON,OFF) then the on state is ok and the off not updating…

1 Like

vendor.js:197 [Violation] Added non-passive event listener to a scroll-blocking ‘touchstart’ event. Consider marking event handler as ‘passive’ to make the page more responsive. See https://www.chromestatus.com/feature/5745543795965952
|h|@|vendor.js:197|
|—|---|—|
|on|@|vendor.js:198|
|W.|@|vendor.js:201|
|bindEvents|@|vendor.js:556|
|manageEventsBindings|@|vendor.js:556|
|resetSlider|@|vendor.js:556|
|(anonymous)|@|vendor.js:556|
|$broadcast|@|vendor.js:149|
|(anonymous)|@|dashboard.view.controller.js:42|
|(anonymous)|@|vendor.js:160|
|f|@|vendor.js:45|
|(anonymous)|@|vendor.js:48|

I get this Violation messages. Running on chrome.

Habpanel does not update on its own, on refreshing it gets updated. No errors.

Any ideas?

Over here the same problem. Items state doesn’t change on the habpanel. Even when I change the state of an item. It directly goes back to that first state? Strange.

Since updating to 2.5.8 habpanel doesn’t update automatically. I have tried Chrome and Firefox on Windows 10 and Chrome on an Android tablet so I don’t think it is the browser.
Can anyone suggest what has changed?

Same problem here. Since upgrading to 2.5.9, HabPanel does not appear to be refreshing automatically. Seeing refresh issues for all zwave devices, astro sun/moon position events not triggering update visuals on display, and weather events not being refreshed without manual intervention.

I also recently started having this problem. HabPanel is running in Kiosk Mode on a kitchen-mounted Kindle Fire HD and a couple of days ago, updating simply stopped. I can still press buttons, but even if the item changes, the buttons on the panel don’t display this change to make the state match, I need to refresh the page.

Very annoying and has made the kitchen HabPanel almost completely non-functional.

I have the exact same problem. Group switch does not update when turning it on…