HABPanelViewer 0.9.24

android
habpanel
Tags: #<Tag:0x00007fe0661f2ef0> #<Tag:0x00007fe0661f2b30>

(Sid Amos) #562

@vbier, at the moment, I do not use motion detection, yet. The tablet is always ON. I am still in testing of everything, so I just send the CAPTURE_CAMERA command every now and then. I find it a potentially useful feature, but have not yet decided about how I will use it (through rules). I just think that it would be at least nice to know that it works reliable.

I am willing to do more testing, if it possibly helps. I just think that me reporting that it did not work on one occasion does not help much. Hence the question about logging.


(Volker Bier) #563

@sidamos, I have created an issue for the problem in my github project, see https://github.com/vbier/habpanelviewer/issues/26.
I have already made some changes and posted a link to the test version in the issue. It would be nice if you could test if this works better for you (I captured 50 photos in a row without problems). And can we please continue communication regarding the problem in the issue instead of here?


(Sid Amos) #564

@vbier, ok, testing now and will report into the issue. Thanks!


(Alex) #565

Hey @vbier, thanks for this great product. I like it!

Today, i got my new Trekstor Surftab K13 (Android 8.0). I figured out a Problem. With this Tablet it seems that KEEP_SCREEN_ON will not work. The screen will be activated but after 15 seconds it switched off. Is there any chance to change this?

Greetings Alex


(Volker Bier) #566

Can you test if this apk fixes the problem:
https://github.com/vbier/habpanelviewer/raw/keepScreenOnOreo/app-debug.apk


(Jörg Schreiner) #567

Volker,
In my case your app brings the java.exe on my OpenHAB server up to 90% CPU usage.
Utilization is growing until it reaches max.
As soon, as I disable the app, the CPU utilization goes down to less than 10%.
Client: Samsund Galaxy Note 10.1 (2014), Android 7
Server: Windows Home Serve 2011, Oracle Java (191)
App: 0.9.22 from Google Play Store


(Alex) #568

I, am sorry but there ist the same problem with that apk. Should i create an logcat log? Thanks for your great work!


(Volker Bier) #569

@Joerg_Schreiner, what does the openHAB event log show when the app is running? Do you see lots of updates?

@highspeedwotschke, an adb log might help to find the problem.


(Jörg Schreiner) #570

Hi Volker,
no entries in eventlog, but in openhab.log.
The issue seems to be related to this issue:


So it doesn’t seem to be a direct issue of the HABPanelviewer, but the viewer is causing the load in OpenHAB due to this issue (http-requests).


(Volker Bier) #571

HPV only makes requests to openHAB to send values. These would show up in the event log as item changes. If you see nothing in the event log, HPV does not make any requests, at least in theory.


(Bo Biene) #572

Hi @vbier,

HABPanelViewer is a great app.
I’m planning to use it on a FireTab.
Currently i try to disable the screen when no motion is detected and switch the screen on again when motion is present.
I have created a rule posting to the command item when it changes.

Turning the screen into DIM is no problem. But i’m not recieving a motion change when the screen is in dim state.

Is it a tecnical limitation?
Is it a issue withe the FireTab, or am i dooing somthing wrong?

My rule is:

rule “Screen Control” when Item FireTab_Motion changed
or Item FireTab_Usage changed
then
logInfo(“firetab”, “Motion changed”)
if( FireTab_Motion.state == CLOSED)
{
FireTab_Command.sendCommand(“KEEP_SCREEN_ON”);
}
else
{
FireTab_Command.sendCommand(“SCREEN_DIM”);
}
end


(Volker Bier) #573

Have you tested motion detection by using the preview or system information? Have you read how motion detection is expected to work in the app help? The rule looks good to me.


(Bo Biene) #574

Hi @vbier,

i have tested it with the preview enabled and disabled.
In the Log of the openHAB i can see that i receive the FireTab_Motion CLOSE / OPEN and the rule is executed.
But this only happens when the device screen is ON.
As soon as i sent the SCREEN_DIM the screen is black, but the motion change is not fired.
If i tap on the screen, it is enabled again and i receive the motion change event (if there is motion in front of the camera).


(Volker Bier) #575

You can send me an adb log and I can check if I can see something in there. Check the wiki page for instructions if you need them: https://github.com/vbier/habpanelviewer/wiki/How-to-generate-an-adb-log

Anybody else using this on a Fire Tablet who can help out?


(RW) #576

I have the same issue, not only on the Fire 7 but also on the other tablets. Motion detection did not work for me when the screen is dimmed or off. The rule fires them command but it is not appearing in the command log in HPV. Tried also with the lollipop option and previews.
I use Hue motion detection sensors now so I did not follow up on this issue.


(Bo Biene) #577

Hi @vbier,

i have created the requested logs: https://pastebin.com/82WJdB9A

They should contain on wait for DIM and activation via screen touch and after the second DIM i just produced som motion in front of the camera.
In the log i can see that the camera event stopped as soon as the screen was dimmed.


(Volker Bier) #578

This is something I hadn’t thought about when adding SCREEN_DIM. Since I never used it and only added it for other peoples benefit, I never realized this would not work together with motion detection. I have created an issue for it here: https://github.com/vbier/habpanelviewer/issues/30 and will have to think about how to fix it.


(B Smit) #579

Does anybody have the ‘BLUETOOTH_ON’ command working? I get an error saying ‘Need BLUETOOTH permission: Neither user 10151 nor current process has android.permission.BLUETOOTH.’ (the message is cropped at the last dot)

I’m running v 0.9.22 from the app store on a Galaxy Tab S2 running android 7.0
The app is set as device administrator.


(Volker Bier) #580

@BoBiene: here is a test version that should keep motion detection running when the screen is dimmed:
https://github.com/vbier/habpanelviewer/raw/cameraService/app-debug.apk. Can you please install and test?

@B_Smit: i just tested BLUETOOTH_ON on my device and it works. I am wondering that android.permission.BLUETOOTH is needed for you, I have added it to this test build:
https://github.com/vbier/habpanelviewer/raw/addBtPerm/app-debug.apk. Can you please check if this works for you?


(Bo Biene) #581

Hi @vbier,

i have installed the debug version, the preview window is only showing some times.
When i can see it, the video is rotated by 90deg and the image looks stretched.
There is no motion detection preview (the boxes, when motion is detected).
I get no motion change event in my openHAB item.
Log is here: https://pastebin.com/5uyTuj7i