HABPanelViewer 0.9.24

Tags: #<Tag:0x00007fe05e491bc8> #<Tag:0x00007fe05e4914c0>

(Michael Ritterbusch) #41

Is your tablet on same wifi/network as PC? What if you put in server by IP instead of name. ex. http://192.168.1.x:8080 ?

(Michael Ritterbusch) #42

I would think that would be likely/possibility once it gets a little more tested/mature.

(Peter Van Hanegem) #43

Yes it is. I tried all the combo’s, same problem.

I can reach my router (

(Volker Bier) #44

As this has nothing to do with the topic, it would be smarter to create a separate thread.

Have you configured your router in a way that it allows your tablet to access other devices in your network?

(Peter Van Hanegem) #45

I did but nobody is reacting, so i thought to asked here also.

I can reach my router/ap’s/qnap with my phone/tablet, just not the openhab (i can reach the raspberry by using ssh with my phone)

(Volker Bier) #46

I have just pushed an update that waits for network connection before loading the page.

(Volker Bier) #47

Another app update. Thanks to @miker the app should now be compatible with android 4.4+. Note that some functionality will be disabled for older android versions. This is described in the Readme.

I also added live update of entries in the Status Information.

(Jürgen Baginski) #48

Tried to use the HABPanelViewer on my Android 4.4 Phone, however I’m stuck at the page “Webpage not available”. What makes me curious is that it seems to be asking for http://openhabianpi:8080
My system isn’t named such! Why is the app calling the system by this name? Yes, the initial name was openhabianpi, but I changed it!
I’m connecting via VPN and can have a look onto HABPanel via the browser using the correct name!

(Volker Bier) #49

Have you changed the URL in the settings? Openhabianpi ist not hard coded in the app, and when i change it in the settings it works as it should.

(Jürgen Baginski) #50

Stupid question, which settings?
I just put the .app on the phone , installed and this page is coming up.
For me there is no 9 possible way to select any settings while using the app ( neither on the mentioned page nor by pressing or long pressing a hardware button. ).

(Volker Bier) #51

Swipe right starting from the left edge of the screen to pull the menu open.

(Jürgen Baginski) #52

Sorry, I didn’t think of that way.
I was more focused on the android ways to show a menu, which do change from device to device.
It is working now, although I have no idea where the original name of the system would have been saved.

(Volker Bier) #53

This is the default value for the url setting.

I am currently implementing mDNS discovery of the openHAB server, and will remove this once the discovery works. This makes it easier for new installs, where the app will find the openHAB server automatically on the LAN.

(Alex) #54

Hi, after I changed the URL I only get a black screen (with the nav buttons in the bottom) Menu works ok. Restarting the app did not help.
Any clue?

(Michael Ritterbusch) #55

Can you test by using IP address if you haven’t already? Make sure you have the full URL ex.

(Jürgen Baginski) #56

Sounds as if HABPANEL is trying to get its settings from local storage, where it finds nothing so far. Try to switch to the server settings.

(Alex) #57

@miker Yes I have the adress similar like this, just another IP. Work fine in chrome.
@opus I can’t since the Habpanel menu is even not shown. there is really just black.

If I try a not exsting site I get an error page, so that is ok. My assumtion is that something is wrong with displaing the page.
I am using a Galaxy Tab 2 10.1 inch.

(Volker Bier) #58

I use the same tablet, so this should work. Have you disabled the kiosk mode? This is required for the first start, as otherwise you can not open the menu to set up HABPanel.
The start panel should also be empty in the settings in order to be able to set up HABPanel.

(Alex) #59

I just checked and it was disabled. Strange thing is when I disable and enable Kios mode I see the habpanel menu flashing up for 1 sec and disapearing again.
I am using a custom rom with android 6.0.1
Habpanel shows ok in the “app Fully Kiosk Browser”.

Any more tips please? :slight_smile:

(Volker Bier) #60

I have just pushed version 0.9.3:

  • fixes the sometimes missing motion detection preview
  • adds mDNS discovery for the openHAB server (this is triggered on the first start and whenever the URL is made empty in the settings) and removed the URL default value
  • added HTTPS support (this worked before with a valid certificate, but not with the standard openHAB certificate. i have added an option that allows to ignore invalid vertificates coming from the configured URL)
  • improved speed of app startup and wakeup behaviour

In case you want to switch over to https, install the new version and empty the openHAB URL in the settngs. This will trigger mDNS discovery and this will hopefully find the HTTPS connection to openHAB. In case you get a certificate error, check the option to ignore invalid certifcates from the openHAB URL in the settings.