HABPanelViewer 0.9.25

Tags: #<Tag:0x00007f1e5bff0e58> #<Tag:0x00007f1e5bff0d18>
(Norman) #422

Hi Volker,

nope, this doesnt work - it wont update items right after installation - time is counting and all but if I tap a button to toggle a light then the button state is not updated, I have to manually refresh the page to update.

Hardware support is disabled, all other settings at default, addresses are all correct like in my previous postings.

Maybe a bug you overlooked?


(Maciej Eckstein) #423

Guys, I could use some help running the app.
I use a new rooted Sibo 896s (octacore, finally it is responsive!) running Android 6 and when using HabPanelViewer I do not get the CSS working ( in the HabPanel setings I have “This Browser is not compatible with Themes”)
Reading through this entire post it looks like a webview issue. Is that fixable on a rooted device?
I tried install google webview component and setting now looks the following

but the the app does not choose the newer google version.



(Norman) #424


Hi Volker,

Weird, the latest Fully Kiosk Browser runs smoothly since yesterday. I’ll do some further testing …


(Volker Bier) #425

@Norm, all the normal HABPanel functionality (clicking buttons, updating values ) is completely handled by the embedded webview component. None of my code is involved for this. So it is unlikely that this is caused by a bug in my code. Grab an adb log and send it to me and I will check if I can see something in there.

@xsherlock, an app can not choose the webview version itself. It is a setting in the android developer settings.
If you update to 0.9.20, Status Information additionally shows which of the available webview version is used.


(Maciej Eckstein) #426

How do you change that setting, I cant see that in settings/developer options from the device level menu, should I change it from the ADB over USB? any how to?
The google play store is still serving 9.19 I see 9.20 app-debug.apk in the github/releases is that a file to install?
That does not install on my device, says app not installed.


(Volker Bier) #427

Looks like what I told you is wrong. From reading on the internet, selecting the webview implementation in the settings is only available starting with Android 7. In Android 6, there should only be one webview version, and that is the one installable and updateable as a standalone app.

I have no idea how you got 2 versions on your tablet. To me, It looks like there is a problem in the android version on your tablet. If HPV is really showing it is using the old webview version, you may try to contact the Sibo support. See this similar thread about the same problem on Odroid C2.

Regarding the update issue: did you uninstall the HPV version from the play store before installing the apk?


(Maciej Eckstein) #428

with 9.20 I can see what was suspected that it is hard using the outdated webview.

I spent substantial time researching the behaviour of webview and I’m very confused how it should behave in Android 6.0.1.
But As in your post it looks that latest version of the webview is not overwriting the old one as it is named differently “google.com.android.webview” and not “com.android.webview”

Sibo support is rubbish, for every question the salesdroid will write in a broken english that this is how it is and they are sorry it cant be changed. I’m 99% sure he didn’t even bother to ask the software guys. Same for the warranty claims as I already have couple units dead. If only anyone else in a word would produce a POE tablet with flush mounting with a wall I would switch in a blink.


(Norman) #429


yes, I do know that. And, on a final note, also Fully Kiosk Browser stopped working after two days - totally frozen. Anyway, I will have a search if there is any Android 5.x ROM out there somewhere, I guess this is the only way to get hold of a new webview component.

If I don’t succeed then I will consider buying new tablets for my “smart” home. I wonder what exactly the openHAB team changed since the last update and why - this is not only me but others too who are affected by this. And I will have to spend a lot of money on new tablets because of this.

Thanks for the support, Volker.


(Norman) #430

Funny note: I reset the tablet again and installed HPV from the app store - it shows the time just fine but does not update the buttons and items and so forth. Fully Kiosk Browser updates the buttons and items just fine and with very little lag but does not show the time continously - it freezes after a while (sometimes minutes, sometimes hours).

At the moment I help myself with HPV (which I really like) and use the SCREEN_ON command - I assume HPV then refreshes the screen, so all is good. This gives me time to search for alternatives.


(Cyrille Demaret) #431


I have a problem with the reporting of motions to Openhab. HABPanelViewer detects motions according to the System Info (I see detected motions number increasing) page but It only reports reports this when I close the application :

2018-07-20 19:01:21.144 [vent.ItemStateChangedEvent] - Motion_Tablet changed from CLOSED to OPEN

and this when I open it :

2018-07-20 19:01:35.438 [vent.ItemStateChangedEvent] - Motion_Tablet changed from OPEN to CLOSED

Is there something I can check?

Also, Is there an option to turn on the tablet when a motion is detected without using an OpenHAB rule to send a remote command to turn the screen on using the motion detection item?

Best regards,



(Volker Bier) #432

The app only reports motion when it first detects it by closing the contact. If no further motion has been detected in a period of 30 seconds, the contact will be opened. This repeats every time new motion has been detected.

I have added a todo to describe this in more detail in the help file.



(Cyrille Demaret) #433

I cannot get the application to send any update to the item. I start the application, the application update the item to CLOSED and then nothing happens ever except If I restart the application. According to the system information screen, the tablet detect motions correctly.

I have also tried to install the application to another tablet (Kindle Fire 7) but the status in the menu always stays to “not connected” even If I have the welcome screen of openhab displayed. Do you have any idea why it detect it as not connected?

Thank you for your work.

Edit: sorry, it’s working on my first tablet but the delay between the CLOSED and the OPEN is 1min and not 30 sec.


(Volker Bier) #434

Have you looked at the wiki page for commanding? It describes a few things to do/check if commanding does not work. That should also apply to failed connections.


(Norman) #435


HPV runs quite nicely now but I encountered a crash while sending SCREEN_ON to it. I programmed my house ghost to send the SCREEN_ON command (with sendCommand) whenever it detects motion via a Fibaro motion detector. Most of the times this works perfectly but one out of twenty times the tablet crashes, leaving a blank screen with just the background LEDs on. The tablet needs to be rebootet the hard way in this case - nothing else works. Any ideas how to fix this?


(Volker Bier) #436

Not without a log file.


(Norman) #437

A logfile from what (HPV, openhab, android…) and how do I do that?

I read your wiki pages and what not but no mentioning a log or debug function.


(Volker Bier) #438

An ADB log. Google for instructions on how to geht one.


(Chris S) #439

Does the Amazon Fire tablets allow the START_APP command? I am using the PlayStore version of HPV. My command log gets the message and when i click on it, I get: “length=4; index=4”

I used the package name com.meshare as well as com.meshare.ui.login.Splash


(Volker Bier) #440

Please update to 0.9.20. It contains a fix for the START_APP command.


(Chris S) #441

Awesome! It worked! Any idea when that version will hit the play store?