HABPanelViewer 0.9.25

Tags: #<Tag:0x00007f1e5b990ea0> #<Tag:0x00007f1e5b990d60>
(Volker Bier) #582

@BoBiene, it worked flawlessly on my Nexus 5 running 8.1 (which is my development device), but I had the same symptoms on my mobile when I tested it after your reply.

I have now reverted my changes and tried something else, which works on both of my devices. I have posted a link to the apk in the github issue. Can you please test and report back in the issue?


(B Smit) #583

Yes! it works now!


(Jörg Schreiner) #584

@Vbier. Is it possible, that disabling caching in HPV s causing this issue?
This might explain the entries in openhab.log instead of event.log.


(Volker Bier) #585

I would expect that HPV does only load pages when it is used. But you can easily enable caching and see if that changes anything.


(Jörg Schreiner) #586

I was not able to reproduce this behaviour and I’m very happy with the tool.
One question: Was there a reason to define StartupTime and connectedTime as Number instead of DateTime?
Thanks Joerg


(Volker Bier) #587

No, there wasn’t, or at least I cannot remember. I just put it on my todo list to change them to DateTime type.


(Volker Bier) #588

I have just released version 0.9.24 on github. As usual, it will take a few days until it is available on fdroid.


  • simplify camera code, move it to separate thread to get rid of ANRs
  • add startup indicator
  • improve reconnect behaviour
  • don’t try to set values using rest API when not connected with SSE
  • add setting for allowing video auto-play in browser
  • add wiki access to help activity, add help intro page
  • improve command documentation in help file
  • BUG: correctly disable backlight when SCREEN_DIM is received
  • BUG: fix camera problems on specific devices (e.g. Fire Tab)
  • BUG: fix missing default for menu position preference with german locale
  • BUG: add missing bluetooth permission that is needed on some devices for toggling bluetooth
  • BUG: fix wrong preview orientation if v1 api is used after having used v2 api with rotated device
  • BUG: fixed crash in intro
1 Like

(Jesper Lauritsen) #589

Is this fix (camera wake after SCREEN_DIM) in the new version? I am using a Kiosk Browser instead of HABPanelViewer untill this is fixed, so I hope so :slight_smile:


(Volker Bier) #590



(Sid Amos) #591

After restarting openHAB, HPV does not listen to commands anymore. I have to also restart HBV (manually at the tablet). Anyone else seeing this?


(Sid Amos) #592

I have installed 0.9.24 release from Github now also on my Nexus 7 (LineageOS, Android 7.1.2, Chrome 71 set as Webview).

I have some problems and before I file an issue, I’d like to ask for opinions/known workarounds:

  1. I am starting in Kiosk mode. But the web page is not at the top (small black bar at the top). I have to manually scroll it up a bit, so that I see the bottom widget fully. It’s only a little that is missing.

  2. The RELOAD command does not work. Command log says “Flash control not available on this device”. Why is flash needed for reload? The RESTART command works however.

  3. Camera snapshot is working only after I manually allowed camera right in App Info. But the image is pretty dark in poor light. It is a bit brighter with Pre-Lollipop, but that one is crashy. This may be a Nexus 7 limitation though.



(Volker Bier) #593
  1. And the behavior differs from the old version? I can’t remember having changed anything related to the webview. I also cannot reproduce this here.
  2. This is a bug. It only occurs on devices without LED: https://github.com/vbier/habpanelviewer/issues/31
  3. Have you tried to increase the delay as described in the help?

(Sid Amos) #594
  1. I guess, it is not different from old versions. But I just started to add the Nexus 7 as a 2nd tablet and with the dashboard I am using for that, I have this problem. I can try to fix that probably with CSS or when setting the start page, HPV could remember the scroll position, that would be cool.
  2. Thanks!
  3. I have raised it to 500. Does not seem to make a difference.

Can you also say something about my previous posting above (lost connection after openHAB restart)?


Connection Lost habpanel?
(Volker Bier) #595

Have not yet had the time to reproduce the reconnection problem. But I have added unit tests especially for connection recovery and these work just as they should.


(Kris K) #596

Hi Volker, not seen it on the Play Store as yet? any idea when


(Volker Bier) #597

No, works for me. Does it never work for you with the new version or sporadically? Do you restart normally or did openHAB crash?

No, as i do not publish on the play store, I have no idea if and when it will be done.


(Kris K) #598

No trouble , i installed manually. Hopefully this fixes the connection drop outs


(Volker Bier) #599

Which connection drop outs are you talking about?


(Sid Amos) #600

I installed 0.9.25pre (from 03.02.) and it still says the same error when sending the RELOAD command.

Also, on the same device, I have enabled reload start page when switching on and it does not do that. Of course, once the RELOAD command works, I have a workaround for this issue.


(Volker Bier) #601

Looks like i forgot brackets when trying to fix the problem. I just added them and updated the apk. Can you please retest?