Tags: #<Tag:0x00007fd30f9b7ac8> #<Tag:0x00007fd30f9b7960>

(Mac Fly) #261

Ok … I understand your point of view … to bad … but thanks for your answer …

(Bogumil J.) #262

Thanks for explanation.

  1. I guess the simplest workaround for speech is to install some pay squeezelitetype app on all my tablets :frowning:
  2. Set_volume works fine
  3. I didn’t add anything significantly new, but previously my 10inch tablets were able to deal with charging while running fullscreen mjpeg stream as image widget without dimming. I wonder how much energy consumption is dependent on openhab communication and potential errors existing in habpanel widgets.
    The only I did recently was reinstalling openhab.

(Volker Bier) #263

I am not sure what you requirements are, but you can use openHAB with the Web Audio sink and then have speech by using the say command in rules. This also works with chrome, as the speech is synthesized on the server and the result is streamed to the client.
This outputs the text to all connected tablets, though. If you do not want that, you could mute the tablets you don’t want.

(Ben) #264

Well I really appreciate this browser , but my biggest problem is, that I cannot use my custom css. In the habpanel settings menu it says something about incompatibility of the themes. Has anyone a solution for that kind of issue?

(Volker Bier) #265

Have you tried searching this thread for “theme”?

(Ben) #266

Yes sorry I just read the information about that. Unfortunatelly there’s no chance for my tablet to make it work. No chance for updating my webview.

(Sebastian) #267

Hi guys,

first I wanna say thanks to @vbier Volker for this great app!

I just bought an Amazon Fire 7 to use it as static HABPanel tab with HABPanelViewer.
I read this thread (hope I got everything) and I’m aware of the limitations caused by Amazons special offers lock screen.

Anyway I wonder what is your preferred setup for a Fire tab?

What I figured out so far:

  • :x: if the tab is locked SCREEN_ON doesn’t work (leads to the lock screen)
  • :white_check_mark: KEEP_SCREEN_ON works and the tab never goes to sleep
  • :white_check_mark: now with SCREEN_DIM the screen dims to it’s minimum (actually for me it looks like it is off => see issue below)
  • :white_check_mark: when I touch the screen it dims up to where it came from
  • :white_check_mark: also SCREEN_ON now brings the screen back to its previous dimming level
  • :interrobang: BUT: after sending SCREEN_DIM it looks like the tab gets locked after some time even if KEEP_SCREEN_ON was set?? => waiting for the android screen timer to expire touching the screen or sending SCREEN_ON doesn’t work and pressing the tab’s hardware key brings up the lock screen

Can someone confirm this behaviour? Is this how it should work? Or can this be solved even with the limitations of FireOS?

Would be perfect if after dimming the screen it could be brought back even after hours or days to the previous dimming level

Or are there any other best practise solutions for Fire tabs?


(Volker Bier) #268

All of the mentioned commands do nothing with the screen lock. They just turn the screen on and off (or prevent it from turning off), the lock is completely handled by the OS.

So point one seems to be expected functionality.

Regarding the other point: this seems to be a bug in the code. I will have to look into this when I have time.

(Sebastian) #269

Thanks for your quick answer @vbier
I recognize that my list is a little bit unclear. I know the first point is intended behavior. Just wanted to summerize for myself and maybe others what works and what don’t.

Great! If this is really a bug and can be solved I could use the Fire as planned. Thanks again for your work.


(Webfeger) #270

i use Habpanelviewer on Samsung Galaxy Tab.
if i wake up the tablet from standby i got a blank wite site with follow message: waiting for network connection and this app doesn‘t‘ reload the site.
This tablet is still connected to lan. Not internet.

any solutions for this issue?

if i press the back button, the correct site will be display

(Masssssy) #271

My Nexus 7 does not allow me to enable motion detection. Is this simply not supported at all for this device or do I have the wrong system version, requires root or something else? Guess my backup would be an actual IR motion detector and then send the event to the tablet otherwise.

(Volker Bier) #272

There is no constraint on the device or android version. If you are on Lollipop+, you can try to use both the old and new camera api by changing the appropriate setting. Have you tried that?

What do you mean with the tablet is connected to LAN, but not to internet? Have you restricted the access with your router? What happens if you give internet access to the tablet?

@hannibal29, i have fixed the bug now, but it will take a few days until i will make a new release.

I have worked on new functionality in the last days that allows to capture screenshots and photos on the device and send them to an openHAB image item. I will have to test this a little bit and will create a new relase in a few days.

(Webfeger) #273

in the meanwhile i detected that Galaxy Tab turn off wlan in standby mode. I already set wlan to “always on” but it doesn’t work.

I restricted internet access from tablet. only lan connections are possible.

When use google chrome webapp i see “trying to connect” for one second and all works fine. But habpanelviewer stuck at “waiting for network connection” and doesn’t reload the site. Only if i press the back button, site will reload

(Masssssy) #274

When going into sensor reporting it says “Motion Detection is not available on this device”. Nexus 7 2012, first tried running Lollipop 5.1.1 stock then a custom nougat ROM. Only battery, brightness and volume is available.

(Volker Bier) #275

@Masssssy, I have uploaded a build of the current version with debug information. If have moved all camera related functionality out of the motion detection into separate classes and also added a separate preference section. Can you test if you can enable the camera and/or motion detection in this build?

If not, can you PM me a part of the adb log showing the app start?

Have you granted camera permission to the app?

@hannibal29, this build should also contain the fix for SCREEN_DIM and KEEP_SCREEN_ON combination, can you please test if that fixes your problems?

You can get the apk here: https://github.com/vbier/habpanelviewer/raw/testJar/hpv-debug.apk

(mads m) #276

I am running Habpanelviewer 0.9.18 on a Addroid 4.4.4 SIBO Q896S touchscreen

I am having troble sending the string commands, nothing happens.
I have tryed the following commands:

in the side menu it shows not connected, but I can see and control openhab items
My connected indicator is also sending to my number item,

rule "z-wave stikk"
  Item ihc_zwave_stikk changed
  if (ihc_zwave_stikk.state == ON)

I have also tryed sending the a PUT item state in the rest api, it shows in the log but nohting happens.

What have i done wrong.

(Volker Bier) #278

As long as the app says it is not connected commanding is not possible. What URL do you use for the server? Is it edited manually our found by the discovery?

(Volker Bier) #279

I just tried to reproduce your problem and restricted access to my tablet (Galaxy Tab A), but the page is reloaded as expected once the WIFI connection is re-established.
What I did to reproduce was:

  • restrict WIFI access to LAN on router
  • turn off/on tablet -> page is still visible, no reload
  • turn off/on WIFI -> white page with text is shown, HABPanel is loaded as soon as the WIFI connection is back.

Sorry, but I do not know what else to do.

(mads m) #280


I have tryed with discover server, here it finds a https://myopenhabserver:8443
it works with the site but it is nok show connected

I have also trye’d by typing the adress manually http://myopenhabserver:8080
same problem

I have also tryed with my Samsung Galaxy Tab S, here is the same problem

(Webfeger) #281


how does the discover function work? discover didnt work for me. i set the start page manually . i use follow hostname for openhab server: http:rpi.fritz.box:8080