HABPanelViewer

android
habpanel
Tags: #<Tag:0x00007f0147625aa8> #<Tag:0x00007f0147625940>

(Volker Bier) #482

This is for exporting the settings, I forgot to add the description to the help files. I just added the info.


(Michael Ritterbusch) #483

0.9.22 is now available on Google Play.


(Kris K) #484

Hi Volker, I enter the credentials into the HPV login dialog.

Can it store them?

THanks!


(Kris K) #485

See screenshot


(Volker Bier) #486

HPV does not store the credentials, it only passes them to the HttpAuthHandler. This is a google class that should store the credentials for further use and reuse them on subsequent auth requests.

Saved passwords can be cleared by using the context menu.


(Kris K) #487

How can i ensure they are saved?


(Volker Bier) #488

You can’t. Are you asked every time for your credentials or only after a while/restart? Are the host and realm the same every time?


(Kris K) #489

Every time i open and close the app. I never restart my phone. All details i enter are always the same


(Volker Bier) #490

Most likely the credentials are only stored for the runtime of the application. I could additionally store the credentials across app restarts, but I would have to investigate on how to do this securely.


(Kris K) #491

If it operated like the openhab application it would be perfect. It had local and remote logins and persists my password just fine…


(Norman) #492

@vbier

After installing various updates to my openHAB 2.3 installation everything works again without problems on my old Android 4.x tablet. So after all the discussion above it was not the webviewer component of the android device (I did not change the tablet at all). It happened after an update and disappeared a few months after another update. Makes me wonder about the quality of the openHAB code, because I use it in a few buildings with a lot of devices (WiFi, Z-Wave, Hue and so on) and I fear a complete shutdown because of such bugs in the future. Maybe openHAB is not ready for serious and reliable building automation yet.


(Mac McIlvaine) #493

I have not tried this as yet. But, will.

One question though. You mention it is available in the Amazon app store.

Does it work on the Amazon tablets? I know they “forked” Android so as to create an Amazon advertising platform…
(I will attempt it, but, I won’t have an Amazon tablet until later this week.)


(Mac McIlvaine) #494

I installed on my Android 7.0 phone.

But, when it found my server I selected the main OpenHAB url (I think port 8080??) and it shows the usual selection of openHAB urls, PaperUI, HABmin, etc. and HAPPanel.

When I select HABPanel it shows the same thing I get when I choose from another browser. (which is a habpanel that does not re-size very well on a phone. I’ve never been able to figure out how to get habpanel to resize nicely for different devices…)

I can’t find what is shown here:

image

So, can’t seem to change anything…

What am I missing or doing wrong? :roll_eyes:


(Volker Bier) #495

Swipe from the right side to the middle of the screen (as described in the intro).


(Mac McIlvaine) #496

Thanks! Missed that completely when I read it before I installed. After that I didn’t refer to the original post.
:flushed:
Sorry.


(Volker Bier) #497

@dastrix80, I just submitted a new apk to the main branch that contains the ability to store passwords in a private database so they can be reused after app restart. See the first post for a link to the apk.

Can you please test if this works for you as expected?

Edit: if you are on 0.9.22 you can export the settings before uninstalling and import back after installing the apk.


(Kris K) #498

Hi Volker,

I’ve downloaded it and ill test it :slight_smile: So far so good! I’ve restarted it a few times and it hasn’t asked me for the password - this is great news!! The app is now usable for me. I will test more. Hopefully it operates just like the OpenHAB Android app

thank you for the fast turn around for this feature!


(Kris K) #499

Just an update, working fine and issue fixed! Love your work :smiley:


(Timur) #500

Thank you, Volker.
Update was helpful for me. The app work correctly now.


(Kris K) #501

Hi Volker, just some long time usage info. Its fixed the issue just fine. I do however notice performance issues, the app is very slow to respond and move around inside. I’m using this on a Samsung Galax Note 8 - it’s a very powerful phone.

Thanks
Kris