Habpannel not triggering rule (Failed to execute Rule) [Solved]

Hi everyone I’m having problems with my setup I have been trying to fix it since last night when the rule wouldent run it was working before yesterday

My other buttons and rules are working fine

I have a button called leaving home and have created a trigger event and set up all my rule works perfect when started using PaperUI.

When you press the button it is supposed to send the shutdown command to Kodi and turn everything off to like I say runs fine under PaperUI but once you press the button inside Habpannel nothing happens

All other buttons and other rules working just (TURN OFF SEQUENCE) Buttons LEAVING HOME & BED

In Habpanel add a ‘Switch’ item widget rather than ‘button’, it’s designed for toggling switch items ON/OFF. Button tries to send a string I think and that doesn’t work for the Switch.

If you monitor openhab.log you’ll see the appropriate error message.

I have just used log:display

It returned

Running morning rule works and returns

I have tried a switch still same results

How can I narrow down the problem

Get more details from the log ?

Anyone my only solution at the moment is to start again ?

There are two main log files I’m aware of openhab.log and events.log. From what you’ve shown it looks like the rule is triggering and then failing during execution.

But testing and problem solving is all about breaking down the problem so start at the beginning and prove that the first step is working. You can use events.log to see if a data change is happening i.e. press a button/switch in habpanel and you should see the respective change come through events.log for that item. This will help you prove that habpanel is doing what you want.

But I don’t use paperui to create and test rules so not sure what the “Failed to execute rule ‘rule_1’: 5” means.

Have you tried to restart OH and monitor what openhab.log shows? Any errors reported in your rules?

Thanks for the help

I have managed to solve the problem

There was an error inside my rule all is fine now