Hank Zwave HKZW_MS02 Online but no motion detected

I have just purchased one of the Hank Motion Detectors which has the model code HKZW-MS02

The device is detected perfectly by openhab and once included the device shows as online however no updates to the channels are ever registered by Openhab.

I have enabled debug mode and included the logs in relation to this sensor. I would appreciate if someone could spare the time to look at the logs and suggest any further steps I could take in solving this issue.

hank.txt (7.2 KB)

This log just seems to be part of the initialisation - it doesn’t show what messages are received from the device when motion is detected. Please dont filter the logs as it removes data needed to understand what’s happening.

Thanks for the prompt response and for taking a look. As far as I could see there no additional logs for node 13. (apart from some indicating the device is online and the channels are registered) I grepped the logs as I have quite a few other devices to cut the noise.

Nothing registers in openhab.log or event.log, even when motion is detected as indicated by the green led on the device. It is as though the device is not communicating after initialization.

I will double check this tomorrow and update with complete logs.

Hi Simon,
I’ve had a look at the logs you’ve sent, and don’t see anything (as you suggested). So, this means one of two things -:

  • Either the device is not in range of the controller, so messages are not getting through the mesh and therefore not being processed. Or, it’s not properly included in the network.
  • The device is not configured properly. The most common reason for this sort of thing is if the association isn’t set, or isn’t set correctly. In general, the binding should set this automatically - especially for ZWave+ devices. Sometimes though there are other configuration options that also influence how devices send reports - that’s not so common for a device such as a motion sensor.

I would try to wake up the device to see if you see anything in the log. Normally there is another button to do this, or another sequence of the same button. If nothing is received in the log when you do that, then I think it’s probably out of range, or not included properly in the network.

Range should not be an issue as the device is around 3 ft away from the controller during testing.

I have tried waking the device multiple times manually using the button, still nothing logged.

I will try to exclude and reinclude the device once again and update on the progress. I will reset the device to factory settings once excluded in the hope that helps.

Either the device is not really being woken up (check that you are really using the correct sequence for the wakeup), or the device is out of range, or the device is not really joined the network. Otherwise waking up the device would result in something in the log.

1 Like

If you have debug logs, try the log viewer.
https://www.cd-jackson.com/index.php/openhab/zwave-log-viewer

Good tip on the log viewer thanks.

Having removed and added the device several times (on node 016 now) I still have no progress. Waking the device leaves no trace in the logs as before. The operating manual suggests waking the device is as simple as pressing the button once. There is only the one button on the device.

Although the device is detected by the controller it appears the communication ends there. In Habmin the device shows partially. All the other devices I own have the full name after the node number.

Screenshot from 2020-01-30 19-24-26

The attributes do not fully match the device in the database here: https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/676


My device shows listening and frequently listening as False however the DB suggests these should be True. The manufacturer is also Unknown.

If I try to set a device configuration parameter in Habmin, the status remains at pending.

It is looking more and more like a faulty device to me. Perhaps the next step is to exchange with the supplier?

The manufacturer id is important. The “unknown” comes from HABmin itself.

This looks ok to me. Don’t worry about the manufacturer showing unknown - this is a list in HABmin which has not updated, and clearly the device is being detected fine as it is showing with the correct name.

If nothing is being received when you wake the device, then probably the device is out of range - or you’re not pressing the right sequence of button, or the device has a problem.

Without seeing logs it’s hard to comment further.

You MUST wake the device up - otherwise the device is asleep and the binding cannot transfer the data to the device.

1 Like

Problem solved! It seems that the instructions to wake the device are incorrect, at least for my device.
A single press is confirmed by the LED illuminating but nothing happens, the device stays asleep. To wake the device I need to press the button 3 times in quick succession.

Now that I can wake the device the rest of the configuration was a breeze.

If anyone else is considering one of these devices, first impressions of its performance seem good. The range is excellent. Far better than Aeotec Multisensor 6. Time will tell on battery performance etc.

Thanks all for your support.