Harmony Hub binding not working since a few days ago?

All of a sudden, my Harmony actions and rules stopped working. The error was related to a “null client”, so I tried specifying a qualifier, thinking perhaps that had been a Harmony update that required it, and double checked the IP was still the same (power was cut to the house, so everything restarted, but the IPs have stayed the same).

After adding a qualifier, it still doesnt work. Here’s the relevant errors in the log:

2015-11-01 08:43:33.701 [DEBUG] [b.h.internal.HarmonyHubBinding] - internalReceiveCommand(Harmony_Activity,PowerOff) is called!
2015-11-01 08:43:33.702 [DEBUG] [o.harmonyhub.HarmonyHubGateway] - startActivity for qualifer hh and activity PowerOff
2015-11-01 08:43:33.703 [DEBUG] [o.harmonyhub.HarmonyHubGateway] - running for qualifier hh and client null

The items are defined as

/* Harmony Hub */
String Harmony_Activity "Harmony [%s]" <television> (Living_Room) {harmonyhub="*[hh:currentActivity]" }
String Harmony_PowerOff "Power Off" (Living_Room) {harmonyhub=">[hh:start:PowerOff]" }
String Harmony_Exercise  "Exercise" (Living_Room) {harmonyhub=">[hh:start:Exercise]" }
String Harmony_WatchTV  "Watch TV" (Living_Room) {harmonyhub=">[hh:start:13858434]" }

And in the config:

########## HARMONY REMOTE CONTROLS ##########

Has anyone else had problems with Harmony recently, or can shed some light on the client null error? Thanks in advance!

Hi James, did the failure have any possible relationship to your updating any part of openHAB around the same time? What is the name and date of your harmonyhub binding JAR?

Unless there’s an auto-updater somewhere, not that I know of. Currently running 1.7.0-SNAPSHOT for action, binding and IO JAR. These have been working solidly for months.

Oh, this is ridiculous. Restarted OpenHAB service so I could check the intitialization logs and everything’s back to normal. Perhaps when the power came back on, OpenHAB restarted faster than Harmony and ended up with a “null client”. Sorry!

There is no auto-updater. I had made a code change that was merged almost a month ago, but it sounds like you’re not using it so it couldn’t be the cause. You could possibly try a JAR from a recent build (see here for the addons ZIP file), but I don’t have reason to believe it will help your issue. I don’t have a HarmonyHub myself so I’m not going to be of much use further.

No worries! Your theory sound pretty possible. Glad it’s working!