Hayward Omnilogic Pool Automation Binding

#4 is the method that worked for me. What version of OpenHab are you running? I compiled the jar for 3 and 4, but it’s untested on 3. Im running 4.

Maybe that’s it… Sorry, I am still on OH3. 3.4.1 I think. I should have let you know that!

I haven’t been doing a lot of reading on the forums lately. Is 4.0 ready and stable? And, I’m hoping it’s a little easier than the switch from OH2 to OH3!

But, in the meantime, I’d be glad to try out your 3.0 jar.

The 2023-05-12 jar was compiled for OH3 and OH4. I went ahead and recompiled it…

I’m running 4.0.0.M2 and it is stable. If you are using ECMA scripts, you will need to update them from Nashorn v5.1 to Graal ECMA 2021 v11.

Sorry about the continual delays in testing these out… I hope you had a nice memorial day weekend. I’m still unable to get the new .jar to work. This is the error I get when trying install it from karaf console:

openhab> bundle:install file://home/user1/haywardomnilogic_400.jar
Bundle IDs:
Error executing command: Error installing bundles:
        Unable to install bundle file://home/user1/haywardomnilogic_400.jar: org.osgi.framework.BundleException: Error reading bundle content.

One question, I’m renaming the file ‘haywardomnilogic_400.jar’, is that a problem? Does it for some reason need to stay the same name that you sent? If so, do you know how to make a file name with a space in it work in karaf?

Please upgrade the release binding with the jar file. This is what worked for me.

  1. Do bundle:upgrade ### from home folder, with release binding installed = Binding does not show up on ‘add thing’ page, looks good on the bundle:list

This morning I tested the jar from 5/26/23 (from google drive) and it upgraded fine on my OH4.0.0.M2. I did rename the file to eliminate the spaces without any issues. I went ahead and recompiled it again (for both OH3 and OH4).

If this doesn’t work, I suggest you upgrade to OH4.