Help! been working onm this like 12 hopurs straight ans something is wrong


(Joshua H McIntosh) #1

i havw ubuntu server edition installed on a virtual machine… i installed openhab2 amd this is all im getting

It works !
If you’re seeing this page via a web browser, it means you’ve setup Tomcat successfully. Congratulations!

This is the default Tomcat home page. It can be found on the local filesystem at: /var/lib/tomcat8/webapps/ROOT/index.html

Tomcat8 veterans might be pleased to learn that this system instance of Tomcat is installed with CATALINA_HOME in /usr/share/tomcat8 and CATALINA_BASE in /var/lib/tomcat8, following the rules from /usr/share/doc/tomcat8-common/RUNNING.txt.gz.

You might consider installing the following packages, if you haven’t already done so:

tomcat8-docs: This package installs a web application that allows to browse the Tomcat 8 documentation locally. Once installed, you can access it by clicking here.

tomcat8-examples: This package installs a web application that allows to access the Tomcat 8 Servlet and JSP examples. Once installed, you can access it by clicking here.

tomcat8-admin: This package installs two web applications that can help managing this Tomcat instance. Once installed, you can access the manager webapp and the host-manager webapp.

NOTE: For security reasons, using the manager webapp is restricted to users with role “manager-gui”. The host-manager webapp is restricted to users with role “admin-gui”. Users are defined in /etc/tomcat8/tomcat-users.xml.


(SiHui) #2

Make sure you are calling openHAB via port 8080

http://IP-of-your-machine:8080

https://docs.openhab.org/tutorials/beginner/1sttimesetup.html


(Joshua H McIntosh) #3

i am thats what i get every time


(TonyC) #4

Your default Web App Server (Tomcat) is starting along side of OpenHAB, and grabbing the ports we need. You need to shutdown Tomcat, and possibly restart OpenHAB.

To make it more permanent, you need to disable the Tomcat service from automatically starting.

sudo systemctl is-enabled tomcat8.service

If the above command reports enabled, then run the following disable command.

sudo systemctl disable tomcat8.service

Run the first command again to confirm it’s disabled.

To manually restart OpenHAB to test.

sudo systemctl stop openhab2.service
sudo systemctl start openhab2.service

Check your OpenHAB web Interface again.

Just extra info, to manually stop and start Tomcat you can use these commands.

sudo systemctl stop tomcat8.service
sudo systemctl start tomcat8.service

(Joshua H McIntosh) #5

ok i finally got the gui now to figure out how to use it all
i have a myq-0201 and a chromecast tv and an nvidia sheild atm the my q prolly gonna have to go because i want my garage to open when i arrive on my harley any suggestions?


(TonyC) #6