Help build binding for Paradox Alarm Panel with IP150

ip150
paradox
alarm
Tags: #<Tag:0x00007fe057594e78> #<Tag:0x00007fe057594c20> #<Tag:0x00007fe057594a18>

(Psyciknz) #162

So obviously you didn’t managed to get a connection with ParadoxIP150v2? What does it do when you try to connect?


(Gerrie Pretorius) #163

I actually did no try since I am convinced it will not work.
I can not connect with Babyware by using my IP address.
If babyware cannot connect, I am certain that ParadoxIP150v2 binding is
also not going to work.
It seems that they locked it down to only work when the connection is
coming from their own server.


(Angelos) #164

what error message are you getting in Babyware?

(if I remember well), I have the v2 and it works fine here.


(Gerrie Pretorius) #165

I did try to connect with “Alarmin” android app. and that did not work.


(Angelos) #166

what does your IP150v2 module report in the web interface under “System Information”?

image


(David Cole) #167

I had the same symptoms as you (timeout connecting with babyware) when I had the ip150 script running. You didn’t have the browser connected? Or have you got nothing to work, browser babyware or script?

That sounds like a hardware/firmware issue if out of the box it doesn’t go.


(B K) #168

Hi
I think I can help you with the downgrade, but I can’t find a way to make a PM here for some reason.


(B K) #169

The process of creating an encrypted .puf uses a program called HexToPuf.exe, which can be found in Infield folder (when installed with BW 5.0.15).

The hex file comes from a Cortex M4 64KB device. I don’t exactly know what is outputted in this file, but the file must end with “:00000001FF”, for HexToPuf to open the file.

Paradox identifies firmware by product and family ID.
IP150 uses:
Product ID: 0x6C
Family ID:0xA9

There are two ways of creating a puf for IP150: IP150 and IP150 V3.02 and up.
but when trying to set a version number, the program automatically alters the version number to FF.FF.255.

Looking instead what is outputted in the puf

On line 4-5 there is some kind of integrity check? that is different for each original ip150 puf
Looking at IP150 V4.10.puf, this is “60 ED”, that also repeats in the end of the line and over to the next one.
For 1.39.002, its: “00 BC”

The version number is identified by “04 00 1A” in IP150 V4.10.puf.
For 1.39.002, its “01 39 02”
A puf created with hextopuf that is set to FF.FF.255. = FF FF FF

The version number is repeated three times:
Line 5, 8 and 14

The integrity check on line 4-5 and the version number is the only thing that is different for each header in the puf.

In theory swapping both the integrity check and the version number from IP150 V4.10.puf over to 1.39.002 could work.


(Mathieu Ma) #170

If anyone can help me with a downgrade, I’m having the same issue … :frowning:
PM should work for me (I also tried to get an old babyware, but couldn’t find one … I may try with an even older one (found 2.43.11) - just in case - but I also need a proper older firmware :confused: (tried to get an account on paradox and various dealers without managing)


(renzor) #171

Hello guys, I have an MG5000 control panel.
Downloaded Paradox IP Locate, Babyware and WinLoad.
I can’t see the IP150 module in Paradox IP Locate, but I can see it in my network map and I can access it at 192.168.1.19 but I only have three options Receiver Configuration , I/O Configuration , IP150 Configuration.
I tried connecting through Babyware, it doesn’t work.
I think the problem is this new firmware on the IP150, and I must connect with the panel serial number, but I can;t find it, how can I find it?
/L.E.
Fixed it…sort of… the serial number was the one that I found on the control panel but must be entered without the first 2 characters (f.u paradox), but since I have IP150 v 4.10 I can’t do anything in the web interface, I could upgraded the control panel fw with the In-Field software and serial number but from Babyware I can’t connect via serial number, only if I use their DNS account which I have to pay on the Insite Gold app… so no chance for integration with nothing yet, all solutions available were based on the old IP150 web interface which is now gone.


(Hein) #172

Hi All,

Just starting to contribute to the openhab project and I was working on integrating the PRT3 module via serial on an EVOHD on another project. If it is not too late I am happy to start contributing here. I have the IP150 module, PRT3 module and an EVOHD. I believe the EVOHD has got PIR’s with video feeds although I don’t think you can access those feeds on the IP150. Perhaps that is something we can look into in the future (I haven’t purchased one of those PIR’s to experiment with yet).

Regards


(Woody4165) #173

Hi all

I’m trying to understand how this is working.
Executed the IP150-MQTTv2.py and connected to the IP150 correctly.

As output of the python script I get all the informations like Zones, User and so on.
I then opened mqtt-spy and connected to the mqtt server, and tried to subscribe to some topic to get status changement, like when alarm is armed or disarmed, or when it goes in alarm and in which zone.
I am able to amr and disarm the alarm publishing Paradox/C/P1/(Dis)arm but I’m not able to retrieve information.
Can someone help?
I’m a novice with MQTT.

Thanks


(yozik04) #174

I am also trying to downgrade to a version before 4.0.

Have created the PUF file as @B_K described. Had to downgrade BabyWare to 5.0.15. Version 5.1 does not allow to pick PUF for IP150 module.
Now it is scary to upload the file.

Update: Tried to upload the file. In-Field does not complain but firmware upload fails. Asks for a direct connection, which as I understand is not available for version 4.10…


(Jean Henning) #175

Does anybody on here have Paradox distributor access to their website? The documents “SPXXXX-Serial-Port-Protocol.doc” and “EVO_UDSProtocol.pdf” has been invaluable at understanding the communication protocol together with tracing the packets by Winload (and the awesome work Tertius has done with ParadoxIP150v2). I’m wondering if there isn’t updated versions of these documents on Paradox’s website. I initially found these documents on a local security company’s website but they have subsequently disabled that access. I’m pretty sure they must have gotten those documents from Paradox’s website using a distributor login. Also if we can find out where these documents are located on Paradox’s site, maybe there’s more info that could help us.


(Jean Henning) #176

I noticed that the original links I posted on the MG/SP & EVO serial protocol is no longer available. I’ve made those documents available here: https://www.dropbox.com/sh/dztab03vwdmw8ya/AABNac4VglpRPQMMHVh5myCea?dl=0

EVO: EVO_UDSProtocol.pdf
SP/MG: SPXXXX-Serial-Port-Protocol.doc


(Angelos) #177

Yup. I will check if they published newer versions and let you know soon


(Jean Henning) #178

Any luck yet? I must say that EVO_UDSProtocol.pdf has been the best find to date! Would love to get more updated info on that. Ive been playing around with that document and also a memory map of the EVO48/192 and was able to successfully pull labels for users/zones/areas/modules and even request events and receive live events with a simple Tcp client in C# together with the info in that pdf. The document just seems quite old but whatever info is in there is awesome.


(Jean Henning) #179

Sorry for asking again, but anyone with distributor access that have been able to look for update-to-date (or more) technical documents on the EVO (and any other panel) upload/download protocol (also referred to as the serial protocol) similar to the document I posted (EVO_UDSProtocol.pdf).

Also, there’s a quite active discussion going on at https://github.com/Tertiush/ParadoxIP150v2/issues/5 if you are interested in the EVO & IP150.


(Ingrid Jardillier) #180

Hi everybody,

I’ve just installed an EVO HD at home and I’m very interesting on this post.
@Dim, Is there a newer version that mine : 2.43.11 ? Is it possible to share it with me please ?
Thanks so much.

I have downloaded the ParadoxIP150v2 to test it, but for instance, labels are empty…


(Ingrid Jardillier) #181

Hi Jean !

Is it possible for you to share your C# code. I have a EVO HD and I’m very interesting to see how you retrieve labels. I’ve made a lot of tests, by reading EVO_UDSProtocol.pdf, but without success.

Thank you !