Help. Can't get to openhab

New to Openhab…
Trying to install on a UBUNTU 18.04 LTS server and I can’t seem to be able to open the council using [ipaddrr]:8080 from my pc that i can SSH into the server from.

I have been using the openhabian install and spent hours this weekend trying to get it and no luck. Yes I did install zulu vs 8 (32bit) Java.

I am now wondering if i need to do a manual install as my server is not named openhab and there isn’t a user named openhab (even after openhabian install).

I am new to UBUNTU (but used to do a lot of linux a long time ago) so I am not afraid to get my hands dirty. I plan on running a number of services from this server as I had a spare desktop laying around collecting dust that I thought could be put to good use as apposed to purchasing a pi.

Any assistance is greatly appreciated!

if you can SSH, in a terminal try:

sudo systemctl status openhab2

to see if OpenHAB is running

Did you follow the manual instructions for openHABian? Clone the repo, run openhabian-config, and go through the menu options. NOTE: openhabian-config will install the correct Java for you.

When you use the manual install, it does not change the hostname. If you are on an RPi and use the SD card image install method, it names the machine openhabianpi.

openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor pre
Active: activating (auto-restart) (Result: exit-code) since Mon 2019-04-15 18
Process: 16703 ExecStart=/usr/share/openhab2/runtime/bin/karaf $OPENHAB_STARTM
Main PID: 16703 (code=exited, status=1/FAILURE)

Apr 15 18:34:34 oberon systemd[1]: openhab2.service: Main process exited, code=e
Apr 15 18:34:34 oberon systemd[1]: openhab2.service: Failed with result 'exit-co
lines 1-10/10 (END)
● openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Mon 2019-04-15 18:34:34 CDT; 1s ago

OpenHAB is running
now lets just solve the connection problem with the interface. How are you trying to connect to OpenHAB? Thru a device on the same network?

I used the Package Repository Installation.

It is not a Raspberry Pi. Full Intel PC

Then you haven’t installed openHABian. (NOTE: You can and I recommend that you should use openHABian on any Debian based Linux distro). You’ve just installed openHAB. That won’t change the host name. That won’t install anything else. It only installs OH.

Based on the error you are getting either your Java did not get installed correctly, you have installed the wrong Java runtime, or something else is broken with your OH install. I strongly recommend, especially since you are new to Linux, that you follow the manual instructions for installing openHABian. This will give you Java and OH correctly installed and configured on your Ubuntu server.

Actually it’s not.

This means it’s stuck in a restart loop. OH is trying to start, failing to start, and systemd is trying to start it again.

This also tells use that it failed with a status code of 1. I’m not sure what that means but anything besides 0 is an error.

There is not enough in the logs here to indicate that OH is even getting started so I’m going to guess that Java is messed up.

Ok… I’ll try the manual install and report back.

Make sure it’s the manual install of openHABian.

That is the one I did originally… but I’ll try it again

Went through it again. it said Update vs install. Still no joy.

Process: 1062 ExecStart=/usr/share/openhab2/runtime/bin/karaf $OPENHAB_STARTMODE (code=exited, status=1/FAILURE)
Main PID: 1062 (code=exited, status=1/FAILURE)

Logged in with SSH tonight and got:

Last login: Mon Apr 15 18:32:28 2019 from

          Welcome to            __  _____    ____  _
        ____  ____  ___  ____  / / / /   |  / __ )(_)___ _____
       / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  / / __ `/ __ \
      / /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ / / /_/ / / / /
      \____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/_/\__,_/_/ /_/
              openHAB 2.4.0-1 (Release Build)

Looking for a place to get started? Check out ‘sudo openhabian-config’ and the
documentation at
The openHAB dashboard can be reached at http://oberon:8080
To interact with openHAB on the command line, execute: ‘openhab-cli --help’

Tried running$ openhab-cli console

Logging in as openhab
Failed to get the session.

Never mind!

I re-installed UBUNTU and did a manual install of Openhab (NOT Openhabian) and it worked immediately!

Here are the steps I did and it worked on the first try.

Why is there a user called @BKW and a user called @bkw67 ?


Great question, and one I anticipated.

About a year and a half ago I started to setup openhab and created BKW. I didn’t have anything to use with it yet and repurposed the pi for another use.

Installed an ecobee4 last week and am going to start to install smart switches soon so I took an old pc and started to build out a server for Openhab. I forgot I created the first community account and created the BKW67 one. My post responding to a question above had links in it (direct output from the openhab command “sudo systemctl status openhab2” and the forum locked my account (still locked, which is fine) as I found my login credentials for my original BKW account, and was able to post the results using that account.

Sorry for the confusion.

Figures :slight_smile: Thought something like that or a bug :smiley: