Help getting FireMotD working again Problems with Sudo .\FireMotD -S

Hi everyone having some trouble with my openhab system

i just keep getting a FireMOTD error when SSH’d in

2019-10-20 23:38:00,584: FireMotD: Info: No FireMotD ExportFile detected. Please generate with “sudo .\FireMotD -S”

I have run the command it asks for it doesn’t work , I have also searched on the community and followed things that have worked for other people but i still get the same error anyone have any tips?

There is no point in adding everything i have tried i have tried so much any tips appreciated

Here’s what I did and it works:

cd /opt/FireMotD
sudo ./FireMotD -TF /opt/FireMotD/themes/FireMotD-theme-Gray.json
sudo ./FireMotD -T Gray

Then do the:

sudo ./FireMotD -S

1 Like

Name your OS and openHABian version

Did you try re-installing from openhabian-config menu ?

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

Hi @mstormi Sorry yes your right I should have provided more information im running OH on a RPI3 B+ it’s the latest stable version

I did try too reinstall FireMotd from openhab conf
And I have also tried the above commands too no avail im going too try both again now and will post results

Hi @Johannes_Bauerstatte thanks for the reply i have tried the commands you sent before and it didn’t fix my problem i have tried again too make sure still didn’t fix the problem

2019-10-21 14:08:47,525: FireMotD: Info: No FireMotD ExportFile detected. Please                                                                                         generate with "sudo .\FireMotD -S"

Here is the commands and what was printed out

[14:03:28] openhabian@openHABianPi:~$ cd /opt/FireMotD
[14:03:42] openhabian@openHABianPi:/opt/FireMotD$ sudo ./FireMotD -TF /opt/FireMotD/themes/FireMotD-theme-Gray.json
[sudo] password for openhabian:
2019-10-21 14:03:52,662: FireMotD: Info: No FireMotD ExportFile detected. Please generate with "sudo .\FireMotD -S"
[14:03:52] openhabian@openHABianPi:/opt/FireMotD$ sudo ./FireMotD -T Gray
2019-10-21 14:04:01,655: FireMotD: Info: No FireMotD ExportFile detected. Please generate with "sudo .\FireMotD -S"
[14:04:01] openhabian@openHABianPi:/opt/FireMotD$ sudo ./FireMotD -S
[14:04:29] openhabian@openHABianPi:/opt/FireMotD$


using openhabian-config manual install / firemmotd

[14:08:47] openhabian@openHABianPi:~$ ^C
[14:08:53] openhabian@openHABianPi:~$ sudo openhabian-config
[sudo] password for openhabian:
2019-10-21_14:09:49_BST [openHABian] Checking for root privileges... OK
Hit:1 stretch InRelease
Hit:2 stretch InRelease
Ign:3 stable InRelease
Hit:4 stable Release
Hit:5 stretch InRelease
Hit:6 stretch InRelease
Ign:7 stretch InRelease
Ign:8 stable InRelease
Get:9 stretch Release [5,300 B]
Hit:9 stretch Release
Get:10 stable Release [6,051 B]
Hit:10 stable Release
Reading package lists... Done
2019-10-21_14:09:59_BST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2019-10-21_14:09:59_BST [openHABian] openHABian configuration tool version: [master]v1.5-526(0986fff)
2019-10-21_14:10:00_BST [openHABian] Checking for changes in origin... OK
2019-10-21_14:11:02_BST [openHABian] Downloading and setting up FireMotD...
$ apt-get -y install bc sysstat jq moreutils
Reading package lists... Done
Building dependency tree
Reading state information... Done
bc is already the newest version (1.06.95-9).
jq is already the newest version (1.5+dfsg-1.3).
moreutils is already the newest version (0.60-1).
sysstat is already the newest version (11.4.3-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

$ curl -s -o /tmp/FireMotD

$ /tmp/FireMotD -I
2019-10-21 14:11:07,119: FireMotD: Info: Attempting FireMotD installation
mkdir: cannot create directory '/usr/share/firemotd': File exists
mkdir: cannot create directory '/usr/share/firemotd/themes': File exists
mkdir: cannot create directory '/usr/share/firemotd/templates': File exists
2019-10-21 14:11:43,057: FireMotD: Info: Generating information
2019-10-21 14:11:43,159: FireMotD: Info: Debug mode
2019-10-21 14:11:43,185: FireMotD: Info: FireMotD action save started
2019-10-21 14:11:43,201: FireMotD: Info: Action "save"
2019-10-21 14:11:43,225: FireMotD: Info: Exportfile /usr/share/firemotd/data/FireMotD.json found.
2019-10-21 14:11:43,242: FireMotD: Info: Template type set to all. Overwriting..
2019-10-21 14:11:43,302: FireMotD: Info: Exploring HostIp
2019-10-21 14:11:43,423: FireMotD: Info: Exploring Release
2019-10-21 14:11:43,545: FireMotD: Info: Exploring Kernel
2019-10-21 14:11:43,627: FireMotD: Info: Exploring Platform
2019-10-21 14:11:43,776: FireMotD: Info: Exploring InstallDate
2019-10-21 14:11:43,889: FireMotD: Info: Exploring Updates
2019-10-21 14:11:56,504: FireMotD: Info: Exploring Httpd
2019-10-21 14:11:56,715: FireMotD: Info: Exploring Nginx
2019-10-21 14:11:56,885: FireMotD: Info: Exploring Mysql
2019-10-21 14:11:56,998: FireMotD: Info: Exploring Postgres
2019-10-21 14:11:57,087: FireMotD: Info: Exploring Php
2019-10-21 14:11:57,213: FireMotD: Info: Exploring Elasticsearch
2019-10-21 14:11:57,284: FireMotD: Info: Exploring Logstash
2019-10-21 14:11:57,355: FireMotD: Info: Exploring Kibana
2019-10-21 14:11:57,490: FireMotD: Info: Export system data to "/usr/share/firemotd/data/FireMotD.json" finished.
2019-10-21 14:11:57,525: FireMotD: Info: ExportFile: -rwxrw-rw- 1 root root 3235 Oct 21 14:11 /usr/share/firemotd/data/FireMotD.json
2019-10-21 14:11:57,539: FireMotD: Info: FireMotD action save finished
2019-10-21 14:11:57,556: FireMotD: Info: Generating caches
2019-10-21 14:12:32,754: FireMotD: Info: Generating FireMotD
iiiiiiiiiiiiiii  openHABianPi  iiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii
DD        Ip ->
DD   Release -> Raspbian GNU/Linux 9 (stretch)
DD    Kernel -> Linux 4.19.66-v7+
DD  Platform -> Raspberry Pi 3 Model B Plus Rev 1.3
DD    Uptime -> 0 day(s). 0:5:6
DD CPU Usage -> 22.11% avg over 4 cpu(s) (4 core(s) x 1 socket(s))
DD  CPU Load -> 1m: 4.95, 5m: 3.39, 15m: 1.46
DD    Memory -> Free: 0.05GB (6%), Used: 0.89GB (94%), Total: 0.95GB
DD      Swap -> Free: 0.09GB (99%), Used: 0.00GB (1%), Total: 0.09GB
DD      Root -> Free: 9.59GB (68%), Used: 4.32GB (32%), Total: 14.53GB
DD   Updates -> 0 apt updates available.
DD  Sessions -> 0 session(s)
DD Processes -> 131 running processes of 32768 maximum processes

$ FireMotD -G Gray

$ FireMotD -S
2019-10-21_14:13:02_BST [openHABian] Checking for default openHABian username:password combination... OK
2019-10-21_14:13:02_BST [openHABian] We hope you got what you came for! See you again soon ;)
[14:13:02] openhabian@openHABianPi:~$

Still does not fix the problem it shows what i was missing but does not put it at the top of the SSH window still get the error

login as: openhabian
openhabian@'s password:
Linux openHABianPi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Mon Oct 21 14:12:01 2019 from

2019-10-21 14:14:02,136: FireMotD: Info: No FireMotD ExportFile detected. Please                                                                                         generate with "sudo .\FireMotD -S"

              Welcome to            __  _____    ____  _
            ____  ____  ___  ____  / / / /   |  / __ )(_)___ _____
           / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  / / __ `/ __ \
          / /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ / / /_/ / / / /
          \____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/_/\__,_/_/ /_/
                  openHAB 2.4.0-1 (Release Build)

Looking for a place to get started? Check out 'sudo openhabian-config' and the
documentation at
The openHAB dashboard can be reached at http://openHABianPi:8080
To interact with openHAB on the command line, execute: 'openhab-cli --help'

[14:14:02] openhabian@openHABianPi:~$

@Sharpy Try changing directories and run sudo ./FireMotD -l -v like this:

cd /opt/FireMotD$ sudo ./FireMotD -I -v

Btw, that is an “I” as in I think this will work and not a lower case L.:wink:

Hi again @H102 thanks for the reply tried what you recommended still doesn’t fix my issue

After using commands above did you then use sudo ./FireMotD -S? May need to try reboot then sudo ./FireMotD -S.

Quick github search found this by @mstormi

I have followed that too :frowning: that was one of the original things i tried will try again

EDIT: I have not seen that before i tried something else i found posted on GIT

Is this a new install or an issue that just popped up? Have you noticed any other issues with OH? I ask b/c it may be the start of an s/d card going bad. If you have a spare card maybe try installing a fresh image and see if the problem goes away.

No its an older setup & I have been having the issue for a little while just haven’t fixed it as it wasn’t a major problem

I have not noticed anything else wrong with my setup it works perfectly apart from this and also more recently a problem updating java but others are having that problem too

Trying a fresh install, on new s/d card, is the only other thing I can think of.:thinking: If it works you should be able to make a backup with openhab-cli backup then move the file to the new card.

I’ll keep an eye out and let you know if I come across anything new.

Still stuck with this problem i have managed too get the FireMOTd window too show on the top of my SSH window but it disappears with the same error after a reboot or connecting to a new SSH session any other tips ?

There a cronjob to regularly create the DB, see if running that manually works, eventually remove the DB
(sorry too lazy to look up the details myself I’m sure you’ll find it)

Hi again Markus

I have been looking and i cant find out how to run the command manually that you are talking about i do have a cronjob related too what you are talking about do you mean the one below?

00 00 * * * root perl -e 'sleep int(rand(3600))' && /usr/local/bin/FireMotD -S &>/dev/null
run-parts /etc/cron.daily


It didn’t do anything or didn’t work :frowning:

I have two raspbarries in two houses. Now I wanted to build that one. Unfortunately, it doesn’t show me an Openhab banner at one time (see pictures) where is this exactly defined? And how can I change that. Where is the call with SSH Connect?