Help, I'm ready to give up

Well, I tried several different home automation software provider until I discovered openHAB. Believe me, you will have a lot more pain with the others … or buy off the shelf systems: much more expensive, not flexible, no individual setups, but they work out of the box.

@ThomDietrich as far as contributing to the documentation…that seems even more complicated than installing openHAB. just to make an edit on documentation you have to install something called jekyll and Ruby.

That’s probably why the documentation is for crap. It’s too many steps to edit something. I was going to update some of things I learned but dang it’s too much just to edit a few words.

I understand you are frustrated but this kind of attitude is not going to encourage the five or so people on this very thready who have been trying to help you to continue.

If you don’t want to figure out the process to contribute to the docs yourself then, as @ThomDietrich has offered on many many other threads:

  • create an issue with the updates desired
  • send him a PM
  • create a thread on this forum

The OH 1 docs are a wiki. It can hardly be easier to edit than that. Yet at this point I don’t think many would claim those are better than the OH 2 docs are right now.

The frustration is very real … I understand he is not helping the cause either, but he has a point.

You may remember my frustrations… and they still exist… tried to follow an example (mqttitude) by the book, and it does not work.

Combine this with being able to program a complete shopping website, first in ASP then rewritten to PHP,with 25,000 lines of code, writing other languages, coming from procedural languages; then I tried OH, and all I am asking myself is whether I completely lost it.
Before I post I try tweaking, variations, this that etc. and also have abandoned certain configs to save myself the embarrassment having to ask for help on this forum.
Was it here or elsewhere someone said: “I am not an idiot”… this is how I feel since using OH: literally like an idiot. I understand what it can do, and like it for that… and appreciate your and others’ help tremendously.

Also, it is tough to ask people to use the designer, when it craps itself regularly and then can’t read files for some reason, then needing to delete a directory to get it going. It can’t create a file, etc. I have over the decade selected tools that work, and keep using them, but they work. I tried, but can’t get myself to continue using designer… then the docu, updating it… yes…

Tried the iPhone presence thing. did not work; yes it detects the presence, but since arp does not release it the IP, the ‘not present’ is not detected. Hence, no update to the post or docu.

Back to the mqttitude: one asked to trace log it… I put DEBUG in since the docu says there is only ERROR, WARN, INFO, DEBUG. Tried TRACE, did not error, however, there is also OFF… so two parameters more than the docu states, found by accident.

As I said: I feel like an idiot, because whatever I try hardly works from the start, without reading for hours and maybe posting.

Talk about frustration… :slight_smile:

[end rant]

1 Like

I think Rich already said most I would have answered here. You could just have opened an issue or PMed me. Both are offered choices by me for users like yourself. Besides that, editing the docs page is far from complicated. You just have to click the “Edit” pen symbol on the top right. There is really not more to it. It’s extremely easy, or one google search away.

The offer still stands. Either deal with the Editing topic or just create an issue stating your ideas for change, I’ll be happy to incorporate them. This is not a customer support service. Everyone needs to invest some work, especially those who see the need for improvement. That is actually the reason why I got active in the documentation area of openHAB and this actionless ranting thread is really disappointing to me.

@Max_G I feel your frustration with certain missing or not working aspects. My home also has these little construction sites. I would however not blame openHAB for these. openHAB is a framework allowing you to do all kinds of things by using it’s capabilities. You still have to figure out a way to do what you want to do.

I am for example not using the Smarthome Designer as a consequence of the problems I had with it. If I had more spare time I would either talk to Kai Kreuzer about how to export the functionality to a eclipse plugin or look into some other editor. I would then contribute these effort back to the community. The fact of a not perfect editor is not the fault of the developers in particular but the fault of everyone not doing something about it. If you are an experienced developer, why not look into that?

The iPhone presence is a complicated topic many have been struggling with. That’s the fault of Apple really. There are solutions in the forum and users who are investing real time to provide them to the community. Additionally we are actively looking for a better solution.

Would you please be so kind and edit the following file:

1 Like

done… however, no idea what I am doing :slight_smile:
When I said edit it created a fork…
made the change…
it then said create a pull request…
which I did with a comment.

I hope this leads to the desired result.

Yes it did :thumbsup: Thank you!

Great! Learned something… can do it more often :slight_smile:

1 Like

The docs didn’t give the option of hitting the pencil icon. Now that i
know that I’ll add/ edit some of them to make it clearer for a newbie.

1 Like

For the record, Designer already is Eclipse. It is just a specially packaged version. Exporting it to be a plugin verses a stand alone package should not be that difficult. However, I don’t think (Kai is the expert on Designer)[] and I’m not sure who is.

And even though I keep telling everyone to use designer that doesn’t mean I do not see its limitations and flaws. And I don’t even advocate using it as your primary editor. I tend to write a lot in VIM myself, largely because I’m interacting through ssh. However, when I see thread after thread after thread of people trying debug horribly mangled rules syntax that could have been discovered and corrected in <5 minutes if they just loaded it in Designer…

But I do see that improving Designer is probably pretty high on the list of areas that need improvement for new commers. But I don’t think it is getting that sort of attention. Version 0.9 of Designer was revoked due to a serious bug and it has not yet been addressed.


I understand quite well what your are saying… call me old school, but I work on the principle of elimination and least number of components involved potentially causing issues. As such, I struggle using unreliable (untrusted) tools to troubleshoot a problem.

Also, the examples I gave were not given with the intention to bash OH, but to indicate the existing and continued struggle for a newbie. The effect of one issue here and one issue there leads to endless hours for the simplest of things.

What I will at least give a try,is, when creating new ‘stuff’, that I use the designer for auto-completion and error flagging.

As always, thank you very much for your support of this community.

1 Like

I’ll just counter that if I’m trying to debug an electrical problem in a circuit, even a bad multi-meter is better than nothing at all.

And I don’t take anything you’ve said negatively. And it may be my being grumpy. But I’m kind of sick and tired of answering threads with:

What’s wrong with this rule?

var event == "foo

/* Some comment //
rule some label
    MyItem.state.toString changed to Event
    if MyItem == OFF
        OtherItem.state == ON

Obviously the example above is hyperbole but not exaggerated as much as you would expect.

1 Like

yes, this example is a shocker :slight_smile:

I think as a professional I use professional tools, and for the multimeter; e.g. showing AC when there isn’t and I have to verify with a scope is just awful… then I get a good multimeter (Fluke) :slight_smile:

So i gave up with the hue emulation and google home. Thought I’d try with the weather. Installed the Yahoo Weather binding. followed the docs on setting it up and it never would pull any weather. So I tried to set up the weather binding. I copied the demo items and set up from the docs page, read several forums and tried several different things but Wunderground weather will not get the weather. It’s extremely frustrating when you can’t get something to work even after following the instructions.

I have the Astro binding set up and it gets the sunset and all that.

Here’s my weather.cfg


# location configuration, you can specify multiple locations


Number   Temperature_F    "Temperature [%.2f °F]"  			<temperature>			(Weather, gTemperature)			{weather="locationId=home, type=temperature, property=current, unit=fahrenheit"}
Number   Wind_Speed_Mph       "Windspeed [%.2f mph]"		<wind>		(Weather)		{weather="locationId=home, type=wind, property=speed, unit=mph"}


sitemap home label="Main Menu" { 
	Frame label="Who's Home"{
		Text item=PresenceTommy valuecolor=[online=="NULL"="gray", "ON"="green", "OFF"="red"] icon="boy_3" label="Tommy is [MAP(]"
	Frame label="Weather" {
		Text item=Temperature_F
		Text item=Wind_Speed_Mph
		Text label="Astronomical Data" icon="sun" {
            Text item=Sun_Elevation
            Text item=Sun_Azimuth
            Text item=Sunrise_Time
            Text item=Sunset_Time
            Text item=Moon_Elevation
            Text item=Moon_Azimuth
            Text item=Moon_Phase
	Frame label="House" {
		Text item=gLights {
			Frame label="Hall" { 
				Slider item=hall_light switchSupport
			Frame label="Bedroom" { 
				Slider item=bedroom_lamp switchSupport 
			Frame label="Dining Room" { 
				Slider item=diningroom_light switchSupport 
			Frame label="Bathroom" { 
				Slider item=bathroom_light switchSupport 

And this is the basic ui screen grab

For the record: my stated issue with mqttitude not working, causing lots of work for others, came down to a mistake I made: a typo.
My learning: go with a comb through the changes before posting!

@tdsheppard77, for the weather binding it is a 1.x binding, and hence the weather docs reference the config for 1.x where everything was stored in a single config file. For openHab2, there are separate config files, so you don’t have to prefix the settings with the binding names.

So in your weather.cfg file use the following (note the weather. prefix is removed):


# location configuration, you can specify multiple locations

I also updated the existing ticket about documenting the 1.x bindings with these details. hopefully as this ticket gets worked on this detail will be addressed.

Feel free to add your input too.


Hi Max,
I’m in a pretty similar boat to you. Seasoned programmer in ASP, PHP and other scripting language. Started programming in 1979 (basic if anybody remembers that). Spent the last 20 years in IT.
I installed OH2 from apt-get on raspberry pi (offline) in about 35 minutes and got everything to show up. I have a working web interface. My Mosquito broker is running on my windows machine (just because it was easy to get it done quickly)

I have however, spent the last 3 days trying to figure out how to add the MQTT binding and my sonoff unit to the interface, but alas, I’m totally lost.

Do you mind sharing how you setup mqtt with openhab2?
I currently have the demo enabled and making the changes to the demo in order to understand how the structure works.

I have my own “floor” in the main layout, clicking on my floor i get to my room and I see the light switch.
inside the demo.items file i have:
Switch Sonoff1 “My_Study” (gTFloor) {mqtt="<[mymosquitto:/test/sonoff:state:default"}

I am not sure that the mqtt broker is setup correctly (where does it get defined?) and i am not sure if the text inside the curly brackets is correct.

Thanks in advance.

There is an /etc/openhab2/services/mqtt.cfg which is where you define your broker connection including URL and user names.

At a minimum I would expect to see:


where the stuff in < > gets replaced with your information.

See the mosquitto docs for how to set up the broker on Windows.

Additionally please check this and following comments: ITEAD Sonoff switches and sockets - cheap ESP8266 Wifi+MQTT hardware

I believe everything is nicely discussed there. If you go a bit up, you’ll see, that I promissed to write a tutorial soon. I’ve ordered a dozen new Sonoffs.

Good luck!

That did not fix it. Do I have to do some sort of rule to make it fetch the weather or is it supposed to do it automatically?