Help me please with zigbee2mqtt

Hello everyone.I have a problem.I have a stick сс2538.I installed zigbee2mqtt via sudo and binding are also installed.I don’t understand what to do to set up a stick?what commands should I prescribe?how will he see that the stick is working?

Your Zigbee coordinator is not recommended by Zigbee2MQTT (it may work nevertheless …).

Please read the Zigbee2MQTT documentation.
Make sure that you can control your Zigbee devices from within Zigbee2MQTT.

The basic setup:
Zigbee device <-> Zigbee coordinator <-> Zigbee2MQTT <-> MQTT Broker <-> MQTT Binding (openHAB) <-> (Generic MQTT) Thing

Make sure that your MQTT Broker is up and running: Read the MQTT documentation.

Install the MQTT Binding. Read the Binding documentation.

Create the Things.

broker and binding are also installed!!!and online!!!after installing zigbee2mqtt, what should I do? what should I write in putty to set up the stick?

Have you setup your configuration.yaml?

What do the logs say?

please tell me.What am I doing wrong?I have installed broker and mqtt binding.this is online.then I installed zigbee2mqtt according to the instructions

openHABian | Zigbee2MQTT 4
I don’t know what to do next.I tried to configure the configuration file.I typed a command to open the nano/opt/zigbee2mqtt/data/configuration.yaml configuration file
in this file I wrote…

Required: Home Assistant integration (MQTT discovery)

homeassistant: false

Required: allow new devices to join.

WARNING: Disable this after all devices have been paired!

permit_join: true

Required: MQTT settings


Required: MQTT base topic for zigbee2mqtt MQTT messages

base_topic: zigbee2mqtt

Required: MQTT server URL

server: ‘mqtt://localhost:1883’

Optional: MQTT server authentication user

user: vladimir

Optional: MQTT server authentication password

password: admin

Optional: MQTT client ID

client_id: ‘Zigbee’

Disable self-signed SSL certificates

reject_unauthorized: true

Optional: Include device information to mqtt messages (default: false)

include_device_information: true

Required: serial settings


Required: location of CC2531 USB sniffer

port: /dev/ttyACM0

Optional: disable LED of CC2531 USB sniffer

disable_led: false


output: attribute

what to do next? Maybe I did something wrong before? did I write the configuration file correctly? how do I know if the stick is tuned in or not?

Can you use the code fencing for your configuration file.

Have you started zigbee2mqtt???

I would also suggest adding a frontend to your configuration that and setting the port to one that does not interfere with openhab. That way you can view the logs and settings in your browser

If youhave another computer on your LAN, install MQTT Explorer
( and enter the broker config details and connect. This will show EVERY mqtt message sent through the broker in a very easy to read tree structure,
If you have an android phone, install MQTT Client ( After filling in your broker details and setting the switch at the top to “Enabled”, tap on the broker name you just set up and you will be taken to the “SUBSCRIBE” screen. At the bottom, where it says " Subscribe to a topic" type “+/bridge/state” (without quotes). If everything is working you should see a message saying “online”. You could also subscripe to “+/bridge/#” which will show more messages. Note this app is not ‘real-time’ and does not update as you look at a topic, you need to back out to the main screen and then select a topic again to update.
You could also try “+/#”, which will show just about every topic and every message. Not sure if that would be too much for a phone.

Also have you tried typing “sudo systemctl status zigbee2mqtt”?
Or even “sudo journalctl -u zigbee2mqtt.service -f”?

[quote=“Tougharms, post:8, topic:143532”]
here’s what it says when I wrote the command “sudo systemctl status zigbee2mqtt”

● zigbee2mqtt.service - zigbee2mqtt
Loaded: loaded (/etc/systemd/system/zigbee2mqtt.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2023-01-26 13:20:36 CET; 5s ago
Main PID: 23684 (npm)
Tasks: 19 (limit: 2178)
CGroup: /system.slice/zigbee2mqtt.service
├─23684 npm
├─23695 sh -c node index.js
└─23696 node index.js

Jan 26 13:20:36 openhabian systemd[1]: Started zigbee2mqtt.
Jan 26 13:20:38 openhabian npm[23684]: > zigbee2mqtt@1.29.2 start /opt/zigbee2mqtt
Jan 26 13:20:38 openhabian npm[23684]: > node index.js

Tell me please.did I set up the configuration file correctly?how do I understand that the stick is configured correctly?how do I see my zigbe devices

Look.When i write command: ls -l /dev/serial/by-id I got the answer that the stick is connected to raspberry
lrwxrwxrwx 1 root root 13 Jan 19 12:14 usb-Texas_Instruments_CC2538_USB_CDC-if00 → …/…/ttyACM1

the stick is connected,the zigbee2mqtt service is running where can I see my zigbe devices?

Looks ok. Set up the frontend webUI.
Type “cd /opt/zigbee2mqtt/data”
Edit configuration.yaml - “nano configuration.yaml”



  port: 8090
  host: localhost

NOTE: there are 2 spaces before “port” and “host”
Save and reboot
Use a web broweser on your LAN to navigate to

http://<ip of machine running zigbee2mqtt>:8090

You should see a screen showing any devices you have paired.
If zigbee2mqtt does not run after the reboot, edit configuration.yaml again, change localhost to the proper ip of the machine running zigbee2mqtt

1 Like


don’t match.

1 Like

Good eyes, I missed that