Help needed for KNX rollershutter

Tags: #<Tag:0x00007f616fda8270> #<Tag:0x00007f616fda8180> #<Tag:0x00007f616fda8090>

I’m upgrading my openhab KNX binding to the latest, coming from the legacy version.
I created thr things and items using VSCode (based on the examples and my running instance).

There’s no error in the logs, just no response for the shutter. There is not even bus traffic when trying to do something:

.things:

...
    Thing device Shutter1 [
        address="1.1.27",
        fetch=false,
        pingInterval=300,
        readInterval=3600
    ] {
        Type rollershutter    : O1    "mod16output1"    [ upDown="5/1/0", stopMove="5/1/3", position="5/1/4+<5/1/1" ]
      }
...

.items:

Rollershutter Shutter_garagedoor "Garagepoort" <garagedoor> (Access) { channel="knx:device:interface730:Shutter1:01" }

Another question: is the “autoupdate” option still available?

Which OH2 version do you use? If OH2.3, please add the dpt to position:

[ upDown="5/1/0", stopMove="5/1/3", position="5.001:5/1/4+<5/1/1" ]

Please also consider not to use a number as the first char in a name, whether it is a bridge, a thing, a channel or an item, so better use:

Type rollershutter : Ch1    "mod16output1"    [ upDown="5/1/0", stopMove="5/1/3", position="5.001:5/1/4+<5/1/1" ]

As I copied the line, I determined that in fact you wrote O1 instead of 01 (but only in the channel definition, so no wonder that the item does not work at all)

In question of “autoupdate”: this is an Item-specific configuration, so it’s easy to do it:

Rollershutter Shutter_garagedoor "Garagepoort" <garagedoor> (Access) { channel="knx:device:interface730:Shutter1:Ch1",autoupdate="false" }

Oh my, did I make such a mistake?

Meanwhile, renamed all the channels and the problem is solved!