Help: Openhab 1.7.1 and Insteon device

Looking for a Christmas miracle… I’m at my wits end. I have installed openhab 1.7.1 on a Raspberry Pi, and put a POWERLINC MODEM - INSTEON 2413U USB INTERFACE (DUAL-BAND) into the USB port. I cannot get the set up to turn on/off the lights. Here are some useful facts:

  • I have added the openhab user to the dialout group
  • I have linked the modem to the device(s) and vice-versa
  • I have tried using the modem on a Vera hub, and confirmed that it DID work
  • I have turned debug mode on, and get some useful things back. Specifically:
    When the device starts up it does say:
    2:43:19.128 [INFO ] [.o.b.i.InsteonPLMActiveBinding:592 ] - devices: 2 configured, 0 polling, msgs received: 0
    But, when you try to send a message (i.e. click in UI) I get:
    12:46:38.949 [INFO ] [.o.b.i.InsteonPLMActiveBinding:122 ] - Item: keypadDimmer got command OFF
    12:46:38.951 [DEBUG] [o.o.b.i.i.device.InsteonDevice:170 ] - processing command OFF features: 7
    12:46:38.955 [WARN ] [o.o.b.i.i.device.InsteonDevice:339 ] - gave up waiting for query reply from device 3C.42.42
    12:46:38.961 [DEBUG] [o.o.b.i.i.device.InsteonDevice:344 ] - qe taken off direct: LoadDimmerButton(1:2:6) OUT:Cmd:0x62|toAddress:3C.42.42|messageFlags:0x0F=DIRECT:3:3|command1:0x13|command2:0x00|
    12:46:38.955 [INFO ] [.o.b.i.i.device.CommandHandler:154 ] - LightOnOffCommandHandler: sent msg to switch 3C.42.42 off
    12:46:38.980 [ERROR] [o.o.b.i.i.device.InsteonDevice:358 ] - message write failed for msg OUT:Cmd:0x62|toAddress:3C.42.42|messageFlags:0x0F=DIRECT:3:3|command1:0x13|command2:0x00| no ports configured for instrument 3C.42.42
    at org.openhab.binding.insteonplm.internal.device.InsteonDevice.getPort( ~[na:na]
    at org.openhab.binding.insteonplm.internal.device.InsteonDevice.writeMessage( ~[na:na]
    at org.openhab.binding.insteonplm.internal.device.InsteonDevice.processRequestQueue( ~[na:na]
    at org.openhab.binding.insteonplm.internal.device.RequestQueueManager$ ~[na:na]
    at ~[na:1.6.0_36]

Any help would be more than appreciated. I’m tempted to give up and move to the Vera, even though it’s much less configurable… but at least it works. Or should I be using OH2?

Can you try using the 1.8 snapshot, just replace the 1.7.1 version with the 1.8.0-SNAPSHOT version.

Also, do you ever see anything other than 0 polling and 0 msgs received: Here’s what I have in mine:

2015-12-24 07:16:07.606 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - devices:  60 configured,  60 polling, msgs received:   134

Can you also verify that the device ID is indeed 3C.42.42


Thanks Thanks for the help! I installed using apt-get, is there any easy way to figure out how to use apt-get to grab 1.8, or do I need to figure out where apt-get put the binaries, etc. and go that direction?

Yes, I did validate that I have a device “3C.42.42” many (many) times :smile:. Also upper and lower case.

One other thing: I noticed somewhere that someone had said that Oracle Java was a prerequisite for openhab, but I have the default java for raspberry pi:

pi@raspberrypi /opt $ java -version
java version “1.6.0_36”
OpenJDK Runtime Environment (IcedTea6 1.13.8) (6b36-1.13.8-1~deb7u1+rpi1)
OpenJDK Zero VM (build 23.25-b01, mixed mode)

Could that be the problem? I don’t want to update Java for risk of screwing something else up…

It could be, Try installing Java 8 using the instructions at:

PROBLEM SOLVED! It was because the default Java for Raspberry PI is openjava 1.6, but openhab requires Oracle Java 8 (v 1.8). It turns out that you don’t need to install it, it’s already installed. Simply enter:

`pi@raspberrypi /opt $ sudo update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                                 Priority   Status
  0            /usr/lib/jvm/java-6-openjdk-armhf/jre/bin/java        1057      auto mode
  1            /usr/lib/jvm/java-6-openjdk-armhf/jre/bin/java        1057      manual mode
* 2            /usr/lib/jvm/jdk-8-oracle-arm-vfp-hflt/jre/bin/java   318       manual mode

Press enter to keep the current choice[*], or type selection number: *

Having done that, it works like a charm. Wow… the number of hours I wasted on that!!! I would recommend updating the page on the Raspberry Pi install to include these instructions and/or make the Java8 dependency more clear/default.

Good news! feel free to update the wiki page