Help please - Openhabian installation on Pi4 stucks

I am just trying to install the openhabian image for the Pi4 on my brandnew Pi4 4GB v1.2
I am using the latest image using etcher to write the 32GB SD card putting the card into the PI.
Power and LAN, green LED starts flashing approx. for a minute after that nothing.
Network LEDs orange is stable green is flickering, I can´t find the PI in FING either.
Just downloaded the image again, not helping …

Just checked now openhabian.conf and realized that Wifi settings are already uncommented.
I thought these entries should be commented by default and can be uncommented when required.
So i commented the Wifi entries and the Wfi country entry.

Again stucks after approx 1 minute - Whats wrong here?

Next try, I have entered the WIFI details in openhabian.conf to try now the WIFI boot.
No luck! The green LED stopps after approx a minute. the device doesn´t appear in the LAN.

Is the image maybe corrupt?

How long did you wait?
According to the Documentation you have to
Wait approximately **15-45 minutes** for openHABian to do its magic.

I was waiting multiple times more than 45 minutes, but as I said the green LED is absolutely quite and the Pi doesn´t appear in LAN and I guess it should?
I remember when I did it with my Pi3 it tooks never longer as 15 min

Changed now also the SD card, nothing

In this case have a look into the Troubleshooting section of the documentation.

I did. But I couldn´t find something helping. Therefore I opened this topic.

Maybe to mention again I am using Openhab already on my PI3 … so not completely beginner

Then read more carefully, please.

The Debug guide tells you to attach a monitor & kbd, so you tried that ?

You talk about WiFi but the Debug guide tells you to use Ethernet, so did you try that ?

You could also try the new (alpha!) image from here.

1 Like

I attached a HDMI Monitor and I can see the setup stopps at:

Setting up Ethernet connectivity OK
Ensuring network connectivity …

The Pi is just attached to a switch the LAN cable is working when using on a PC,
so I have no idea what could stop the network connectivity.

How and what to download when trying the alpha image.
I cannot see a download possibility?

set debugmode=maximum in openhabian.conf as explained in the docs


Might it be a possibility that there are people existing as non-coders and not daily working in GIT environments, can it be? Is Openhab not also created for people not Linux experts?

So is it really a problem helping people when asking for a Tip if there is no obvious download link on that page for alpha images?

Can you believe that it is frustrating when having such trouble when expecting a standard installation procedure and getting answers like just read a bit deeper, I better stop now cause it could get rude

Thanks for your help, have a good night you are the man!

with debugmode maximum it only shows rk connectivity instead ensuring network connectivity

You wrote “couldn´t find something helping” although there is a debug guide that is telling you what to try but you apparently did not read or did not follow, so to read again was proper advice, like it or not.
And the image link was just one click away.
You don’t have to take advice. But you shouldn’t insult people trying to help either.

1 Like

So debugging is something for a standard user, like milk shopping in the super market?
Is openhab requiring debugging as default installation method?

maybe I give IOBroker or one of the other smarthome applications a try.
Debugging isn´t for me and for sure not acceptable for many other users (possible users not even able to install openhab).

Am I or is it you who is on the wrong track here - think about it in your nutshell of debugging and set maximum debugging …

Maybe even as a sustaining member you aren´t always on the right track…

Good luck with that!!

Debugging is not standard. It appears you have a connectivity issue. You stated Wifi had issue, then a cable Ethernet had issue.

Seems you have an internet problem. The install worked flawlessly for me.
Please instead of complaining provide some details on the errors.

Clicking on the first build image entry will lead you to the downloadable image.

As I wrote connected to a monitor I can see it stops at

Setting up Ethernet connectivity OK
Ensuring network connectivity …

My internet is working cause I can read and answer here what else could I show you

Sorry not true. I tried that but these files are somehow inactiv I cannot download, did you check?

I know this can be frustrating, I’m sorry for the troubles you are experiencing. You said you have used OH on a Pi3 so you know your way around a bit. It honestly sounds like some other issue. Can you install a different operating system on your new Pi4? Isn’t there an option to install NOOBS or another operating system or something? Maybe just to confirm that there isn’t a problem with your network, your internet connection or the hardware itself?

So cause there seems to be something wrong with the network/internet I restarted the whole sh…
and now it works - time to go to bed.

Sorry for the inconviniences and not agreeing for debugging :slight_smile: