Help with an example of a v3 Alexa thermostat item file

hey guys, im trying to get a heat pump set up with Alexa.

Group  LoungeThermostat    		"Lounge Thermostat"                                	{alexa="Endpoint.Thermostat"}
Number Alexa_Lounge_Temp   		"Temperature [%.1f °C]"    	(LoungeThermostat)   	{channel="hue:0302:00178829a0c5:43:temperature"[profile="offset", offset="2.4°C"]}			
Number Alexa_Lounge_Heating_Setpoint  	"Heat Setpoint [%.1f °C]"  	(LoungeThermostat)   	{channel="zwave:device:b0b17ba4:node25:thermostat_setpoint_heating"}		
Number Alexa_Lounge_Cooling_Setpoint  	"Cool Setpoint [%.1f °C]"  	(LoungeThermostat)   	{channel="zwave:device:b0b17ba4:node25:thermostat_setpoint_cooling"}		
Number Alexa_Lounge_Mode          	"Mode [%s]"               	(LoungeThermostat)   	{channel="zwave:device:b0b17ba4:node25:thermostat_mode"}		

this is what ive got but its not discoverable in Alexa as a thermostat even after asking her to discover devices. any help greatly appreciated.

From a different topic “What happens when you request a thermostat voice command? Usually, if you see not responding in the Alexa app, it could indicate that one or more of the thermostat item states are not defined. Can you see if you get a proper state on the OH side for all components of your Alexa-linked thermostat?”

You didn’t specify the Alexa thermostat components. You should check the thermostat configuration examples in the documentation.

On a side note, your thermostat temperature item is linked to the hue binding?

I’ve tried copying and pasting the sample config and then adding the channels but it gives an error in the logs, hence asking to see someone’s working item file.

Here you go. I used metadata labels to simplify the configuration.

Group  LoungeThermostat    		"Lounge Thermostat"                                	{alexa="Thermostat"}
Number Alexa_Lounge_Temp   		"Temperature [%.1f °C]"    	(LoungeThermostat)   	{alexa="CurrentTemperature", channel="hue:0302:00178829a0c5:43:temperature"[profile="offset", offset="2.4°C"]}			
Number Alexa_Lounge_Heating_Setpoint  	"Heat Setpoint [%.1f °C]"  	(LoungeThermostat)   	{alexa="LowerTemperature", channel="zwave:device:b0b17ba4:node25:thermostat_setpoint_heating"}		
Number Alexa_Lounge_Cooling_Setpoint  	"Cool Setpoint [%.1f °C]"  	(LoungeThermostat)   	{alexa="UpperTemperature", channel="zwave:device:b0b17ba4:node25:thermostat_setpoint_cooling"}		
Number Alexa_Lounge_Mode          	"Mode [%s]"               	(LoungeThermostat)   	{alexa="HeatingCoolingMode", channel="zwave:device:b0b17ba4:node25:thermostat_mode"}		

Since you are using the zwave binding for the thermostat mode item, the skill will default the mode mapping as OFF=0,HEAT=1,COOL=2,AUTO=3. If you need to update that mapping, you will need to add it to the metadata parameter.