Help with Json transforms

ok I am on openhab 3.x

I am trying to gather data from my wall panel
my wall panel is loading hab panel through
the wall panel android app

but I am having trouble getting it to read the Mqtt
I am not great at Json stuff yet

so one payload type is
this is for a motion contact

and this other one I want to break out into a few items
with Json I have done this with Tasmota devices but for some reason
I just can’t get the format right

charging $.charging
value $.value
acPlugged $.acPlugged

and so on. This is about as simple as it gets.

You’ll create a separate Channel for each field and set up the JSONPATH transform to select the different values for each Channel.

thats what I thought too but I am not getting anything
on openhab

I see the messages on Mqtt but openhab is still claiming Null even though there has been several updates

ok I have the charging one working
i think but

for the one that is this


I don’t even really need a trans form do I should just be able to put that in the custom payload should I not

The JSONPATH transform is installed?
Errors in the log?
You’ve confirmed the message are being sent with something like MQTT.fx or MQTt Explorer?
The Bridge Thing is Online?

It really helps a whole lot to not withhold important information like what you’ve tried, errors you are seeing in the logs, etc. All we know is what you tell us and we end up needing to play 20 questions which wastes everyone’s time.

Yes, you don’t need to transform that if it’s always just as you see there.

yes Json has been installed I have used it with several other devices
I will check the logs I am sure its something I am doing wrong
yeah I have Mqttfx open and I have confrimed the messages

I have been copying the actual messages from mqttFx to this thread I generally don’t add any Mqtt items with out confirming messages and syntax this way

I will go dig into the logs

its Fixed I clearly was typing something wrong
I deleted the whole channel and started over works now
not 100% sure what mistake I was making repeatedly
but its fixed

thanks rlkoshak for confirming for me what I thought