Help with z-wave binding and greenwave powernode 6

Is anyone who succesfully run greenwave NP310 on openhab2 ?

Hey Tomek i have 3 of them running successful

Hi Tomibeck
Whiitch version on openhab2 do You run ?
my openhab2.log looks like this
2017-01-20 09:58:29.168 [ERROR] [alization.ZWaveNodeInitStageAdvancer] - NODE 15: Node advancer: Retries exceeded at STATIC_VALUES
The strange is that in openhab2 i see seven switches switch, switch1, …switch6 but device has only six nodes…
When I run openhab 1.8 everything is ok.
It looks like problem with z-wave bind
Which java version do you use ?

Hey Tomek,

I actually misread your post im using the single powernodes.
But the 6th switch could be for resetting the Power readings.


Which version of OH2 (snapshot, beta) and which version of the binding are you using?

There were some issues with devices that were stuck in the initialization process (which results in the Node advancer error log messages you posted), but I think this was solved some weeks (months?) ago.

Hi Stefan
I’m using openhab 2.0.0 release build.
I have problem only with greewave power node. Fibaro wall plug works OK, I have olso few st814 temperature sensors and ZW075 devices and all of them works very well.

Then I think you have to ping Chris (the developer) to take a look.

You should provide the node xml and also a debug log during inclusion of the device.

I sended message to Chris. He said that the will be a fix.
The strange is that i have NO xml files for greenvave devices in /var/lib/openhab2/zwave/ directory…
There are xml files for fibaro, st814, and others but not for two greenwave devices…

This is normal. A zwave device always has a root endpoint - often this is linked to endpoint 1.

That’s not strange - the problem you’re reporting is that the initialisation isn’t completed. Until the initialisation completes, there won’t be an XML file produced.

HI Chris
Thx for yours replay.