Home Connect addon: Looking for beta testers


(Tom) #81

You’re right - UoM is in the latest version of the binding. It wasn’t when I installed the binding - hence the conversion rule.


(Jonas ) #82

Hi @brononius,

I tried to get all available Program names via API. Unfortunately, for my dishwasher I do not get the programs which my appliance supports --> API is useless.

Currently the API returns values like:

Dishcare.Dishwasher.Program.Auto1 or Dishcare.Dishwasher.Program.Eco50
The plugin is using a simple approach to get human readable values.

Algorithm

  1. find last . and get the right part of the string (eg. Eco50)
  2. insert space before numbers an upper cases (eg. Eco 50)

Sorry there is no list. You have to manually collect them and create the mapping.

Greetings,
JB


(Ben) #83

Ahhh, Sometimes it much simpler then you think. :wink:
I just pushed all buttons once on the machine, then did a small grep on SelectedProgramState (=from my item definition) in my logs, and voila. All program definitions. I must stop with overthink things, and just do it.
One thing to know, the spaces in the transform must be replaced by . See list below for reference…

Eco50 = Economisch 50 ÂC
Intensiv70 = Intensief 70 ÂC
Auto2 = Auto 45-65 ÂC
Night\ Wash = Nacht 50 ÂC
Kurz60 = Kort 60 ÂC
Glas40 = Glas 40 ÂC
Quick45 = Snel 45 ÂC
Pre\ Rinse = Voorspoelen

Thanks for this! The binding is a big +

Extra features could be (not really binding related?):

  • Error codes (fe warn about missing salt)
  • Power consumption.

(Stefan M. Haller) #84

Dear Jonas

One more time a big thank you for the efforts you’ve done so far. I’m very pleased with the operational state of washer and dryer.

Cheers
Stefan


(Jonas ) #85

Thanks, :slight_smile:


(Walter) #86

Hi Jonas,
I can only join my previous speakers, a very big thank you! This helps a lot!
At the moment, I have a washing machine, dishwasher, oven and coffee maker, and I’m still testing. So far it runs smoothly.
I miss the power state of the coffee machine, have I missed something there or is it not implemnted yet?


(Jonas ) #87

Hi Walter,

thanks! Power state is not yet implemented. I will add to the todo list.


(Jan Dönges) #88

Hi Jonas,

thanks a lot for this binding, it just works flawlessly and I can finally get rid of the alternatives like IFTTT :wink:

KR Jan


(Johfeu) #89

Hi Jonas,

first, thanks for the effort to build this binding. It was working fine with my washing machine.
But I had problems with the basic UI getting disconnected, rules being delayed and KNX link lost as soon as i installed it. I checked the system and found the raspberry PI going on very high load as when I enabled this binding. It goes back to normal after deinstall.


Is that something others also can see as well?

Any help on how I can possibly fix that?

Thanks,
Johannes


(Patrick) #90

@jb4711: Thanks for the great work. Integrated our new washer (Siemens avantgarde) and it works like a charm!


(Christian Adelbrecht) #91

Thank you for this nice binding! Great work! Works pretty nice!


(Achim) #92

@jb4711: Thanks a lot for this Binding. Works like a charm. I integrated a Bosch Washing Machine into OH2.3 with the Snapshot.


(Marcus) #93

@jb4711: Thanks a lot for this Binding. Works like a charm. I integrated a Siemens Dryer IQ800 series into OH2.4 M7.
As for the transformation I created some map files as well


(Christian Adelbrecht) #94

@jb4711 Thanks a lot.
Works with a SIEMENS-HS658GXS6 very well on OH2.3 Windows


(Andreas Fink) #95

@jb4711
Hi Jonas, thank you a lot for that binding! I’m using it for the moment with my CoffeeMaker (EQ9.S900), where the Binding works great for the moment. I hopefull that BSH is extending the API further and will provide more and more information about the devices.

As I have seen on the changelog of HomeConnect, on the 7th December they provide 2 additional events for the coffee maker:

  • ConsumerProducts.CoffeeMaker.Event.BeanContainerEmpty
  • ConsumerProducts.CoffeeMaker.Event.WaterTankEmpty

Regards,
Andreas


(mattnl ) #96

@jb4711
Hi Jonas,
I am using your binding since the beginning and it is working perfectly.

Today however, after a restart of openhab (I am on the 2.4.0 Release built), I got the following error message in the log (note: The original refresh token was still visible in the Paper UI):

2018-12-18 22:25:33.870 [hingStatusInfoChangedEvent] - 
'homeconnect:api_bridge:xxxxxxxx' changed from OFFLINE 
(COMMUNICATION_ERROR): Communication error! response code: 400, message: Bad 
Request, body: {
  "error": "invalid_grant",
  "error_description": "invalid refresh_token"
} (Tried at Tue Dec 18 22:24:58 CET 2018) to OFFLINE (COMMUNICATION_ERROR): 
Communication error! response code: 400, message: Bad Request, body: {
  "error": "invalid_grant",
  "error_description": "invalid refresh_token"
} (Tried at Tue Dec 18 22:25:33 CET 2018)

After re-creating the refresh token everything is working again without problems.

This is just FYI - and this is also the first time this has happened since August.

Cheers,
Matt


(Ben) #97

I had the same story over here.
Took me a bit to rethink/-find the steps for the token, but it’s online again. :wink:


(DW) #98

After the update to Openhab 2.4 and
the reboot of the system, I have the same problem. :confused:

Communication error! response code: 400, message: Bad Request, body: { “error”: “invalid_grant”, “error_description”: “invalid refresh_token” }


(Patrick) #99

Same here, but getting a new refresh token didn’t solve the problem for me! In the paper UI, when entering the new refresh_token, I still get the error

Status: OFFLINE - COMMUNICATION_ERROR Communication error! response code: 400, message: Bad Request, body: { "error": "invalid_grant", "error_description": "invalid refresh_token" } (Tried at Wed Dec 19 21:40:20 CET 2018)

I followed the guide on github again and everything seemed to work, but not on the openhab2 side. Any idea how to debug this?

Edit: Also tried creating a whole new application in the developer page, same error.


(Jonas ) #100

Hi,

@pgruetter @Pronin777 @brononius @mstehle
I just encountered the same problem yesterday. Very strange! After I created a new refresh token (see Guide) and restarted the binding everything worked again.
My guess is, that the Home-Connect team removed old refresh token from there database. In the current implementation the plugin is using the same refresh token every time. New refresh tokens are ignored. According to developer docs:

refresh_token [mandatory]: refresh token (expires if it wasn’t used within 2 months)

I will have a look at this “problem” and will try use the newest refresh token in the next release.

@pgruetter Can you please try to restart the plugin. I restarted the binding via OSGi shell

@Andreas-Fink

I will add it to the TODO list

Greetings,
JB