Home Connect addon: Looking for beta testers


(Patrick) #121

Thanks a lot for the fix, the new version works so far.

By the way: Do you have a roadmap for integrating an official binding in OH2 ? Apart from the refresh hickups in the past few weeks, the binding seems to be very stable. I would say the beta test is a success :wink:


(Dmitry Zhukovski) #122

Works for me as well ! Started to use it for my dishwasher. Thanks a lot !

One question - is it possible from the binding to kick the actual start of dish washing ? Ofcause if remote is enabled on dishwasher ?


(Y. Gijbels) #123

Same here, it’s working now… tnx.


(Webfeger) #124

Hello,
does this binding alread supports Fridge-Freeze-Combos?
I added this to home connect and want to use it in openhab.

Best regards, Web


(Jonas ) #125

Will add it to the list.

Should work. I tested it against the HomeConnect Simulator.


(Marcel Van Kekeren) #126

I would love to test de binding and have a siemens oven but i seem to be doing something wrong.

i updoaded the binding to the addons folder and after a reboot it shows up onder bindings.

when i go to Inbox> Choose Binding and add a new “HomeConnect Binding”. I get a blank screen and are unable to add some thing.

I also noticed that when i go to bindings > HomeConnect Binding it shows nothing under supported Items.

what is it i’m doing wrong?


(Marcel Van Kekeren) #127

Solved by adding the bridge via the things file after that i could add the bridge via paper UI en add my oven.


(Lukas) #128

Hey Jonas,

I am going to Test your Binding today with three devices:
Coffe-Mashine
Dishwasher
Oven


(Manfred) #129

Hey,
today my EQ9 S900 connected.
It worked fine.

ToDo is still pending. I hope in the future that I can switch the machine on and off.

Yours sincerely Manfred


(Jonas ) #130

Strange. Never encountered such a problem. Glad that it worked out in the end.

Cool, let me know if it worked.

Thanks, for the feedback.

@All: I encountered the “invalid refresh token” oAuth problem again :frowning: . Will try to analyse the logs tomorrow.


(Olli G.) #131

Hey guys,
thanks for this wonderful binding! I reinstalled the newest version (incl. creating a new app on dev side and token etc) and are getting this error after creating coffemachine thing from via autodiscovery (Thing :

    'homeconnect:CoffeeMaker:SIEMENS-TI9575X1DE-68A40E251D47' changed from OFFLINE to OFFLINE (COMMUNICATION_ERROR): Communication error! response code: 403, message: Forbidden, body: {
      "error": {
        "key": "insufficient_scope",
        "description": "Not allowed to access this HomeAppliance"
      }

Any ideas? I’m still on OH2.3.


(Patrick) #132

Just tested again, still works for me. Didn’t change anything since my last post.


(Lukas) #133

Hey Jonas,

i only added the coffemaker today.

One of my main usecases is to turn the machine on and off.
Since you do not support this in your addon right now, i forked your project and build a quick and dirty workaround on my own, which worked for me.
Should i make a Pull-Request on your Git-Project, when it is not only a quick-solution? :slight_smile:


(Jonas ) #134

My first thought was that you used a different account during oAuth authorization. But you said, you’ve added it via autodiscovery which should only show your devices.

“insufficient_scope”

Did you unselected anything on the following page?

@e-Luksch did you encountered a similar problem? Maybe the binding needs additional scopes. Currently it requests IdentifyAppliance Monitor Settings


(Jonas ) #135

Thanks for your help. PRs are very welcome.
Can you please try to sign your commits (see https://www.openhab.org/docs/developer/contributing/contributing.html#sign-your-work).


(Olli G.) #136

Thx 4 answering jb4711, everything was checked on that page correctly :frowning:

//Edit:
You wont believe me if I tell you that I remembered replacing our coffee machine due to a warranty issue. OH2 automatically added the old haid and not he new one. There was also only 1 character different within the serial no so I didn’t recognize… Oooohhhhaaaa…


(Johannes) #137

Hello,

I have again a problem with the connection. I get the folowing error:

'homeconnect:api_bridge:cb18b336' changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): Communication error! response code: 400, message: Bad Request, body: {

  "error": "invalid_grant",

  "error_description": "invalid refresh_token"

} (Tried at Sun Jan 13 18:20:06 CET 2019)

Binding Version from 2018/12/30
Any Ideas? Thank you for your help!


(Thomas Dietrich) #138

Hello,
after installation of binding, items file, thing file and access data of Home Connect from developer page and normal page, there two big failures left, which I cannot drill down. In the moment I cannot see the wood for the trees! Both Home appliances are running fine on the Home Connect iOS app.

  1. from where can I get the complete haID for my ha’s for the thing-file? I am searching for the “XXXXXXXXXXBF” terms of both ha’s in thing-file.
Bridge homeconnect:api_bridge:api_bridge "Home Connect API" [ clientId="AAAAA", clientSecret="BBBBB", refreshToken="CCCCC", simulator=false] {
    // Thing configurations
    Thing dishwasher boschdishwasher  "Bosch Geschirrspüler"  [ haId="BOSCH-SMI68TS06E-XXXXXXXXXXBF" ]
    Thing dryer boschdryer            "Bosch Trockner"        [ haId="BOSCH-WTWH7591-XXXXXXXXXXBF" ]
}

  1. There is a failure appeared in PaperUI for the Home Connect API:
Status: OFFLINE - COMMUNICATION_ERROR Communication error! response code: 503, message: Service Unavailable, body: { "error": "temporarily_unavailable", "error_description": "request rejected by client authorization authority (developer portal)" } (Tried at Mon Jan 14 23:29:46 CET 2019).

Is there anybody who can support me, also as a support for the OH configuration file.
Thanks in advance.


(Patrick) #139

If I remember correctly, I was only able to find that in the PaperUI. Even if you configure it with files, you should be able to find the haID in the inbox.

The second error to me really looks like a temporary connection problem on the server side.


(borcon) #140

Hello,

@johannesbonn: i have the same error after openhab restart.
I have also the binding version from 30.12…

@jb4711: Any ideas? Have you tried to restart openhab?

Thanks