HomeKit 3.1 no response

Hello, everyone,
I’ve been an OpenHAB user for several years, starting with fibaro and Z-Wave, then Enocean piezo buttons and Shellys.

In the meantime I have renovated and installed an additional sub-distributor. In the sub-distributor there is a FI with 16A fuses and the shellys (3x 1PM, 5x dimmer 2 and 2x 2.5 for the roller shutters). Two more 2.5 for roller shutters are located directly behind the switches, the rooms were already finished and it would not have made sense to pry open the walls again. The cables run from the buttons in the rooms to the control cabinet and thus control the Shellys.

So much for my setup, it all works objection free, via the physical switches as well as via openHAB.

Now to my problem:
I would like to set up a HomePod for even more convenience and control the actuators via voice. Installed HomeKit for this, set it up on the iPhone and it worked for about 10 minutes. I completely reinstalled OpenHAB (v3.1) beforehand. Now the Home App only shows “no answer”. I have read a lot of posts about this and then deactivated IP-v6. No improvement.

Is this problem still a common one? How do I get HomeKit to run stable again without reinstalling OpenHAB?

Many greetings

Have you tried to turn off the private wifi address in ios?
Worked for me …

This might be IPV6. If I enable openHAB mdns it works for a bit then fails. If it’s disabled then it works until I restart openHAB.

If i restart openHAB I have to enable openHAB mdns and then disable it again!