Homekit Bundle is installed twice?

I have updated my IOS devices to the Betaversion of IOS16 including also my apple TV´s which are the “homekit servers”

Now i have issues with getting my items into Apple Homekit… I know IOS16 is a beta version and they changed something in Homekit.

I tried to find out if i can do anything to bring it back to work and checked openhab for some suspisios log entries.
i saw that there is a newer version of the homekit addon is available and tried to update…
now i have the issue that i have two instances of homekit running and i am not able to uninstall the old one… it always cames back after restart of OH2.

openhab> bundle:list | grep -i homekit                                                                                                                                                                                                                        
163 x Active x  80 x 2.4.0                   x HomeKit Integration
307 x Active x  80 x 2.5.12                  x openHAB Add-ons :: Bundles :: IO :: Homekit

the Homekit integration is always coming back…
Also i have now two config items in PaperUI

Do anyone have an idea where i have to look at to get rid of this old installations?

Thank you and greetings,
Alex

Hi-

I occasionally get multiple versions of bundles hanging around, and here’s what normally fixes the problem for me:

I assume you’re doing a bundle:uninstall 163 (based on your screenshot), right?

The first thing I’d do is check your addons/ directory to make sure you don’t have a version sitting in there. Then, I would try clearing your openhab cache and restarting. The steps for doing that vary depending on how you’ve installed openhab, so do a search here for “clear cache” if you’re not familiar with the process.

Hopefully that will fix the problem. If not, let us know!

Yes… i deinstalled several times with your mentioned command and the number of the bundle… it get everytime a new number after the a reboot.

I also renamed a file in the addons directory to .bak

openhabian@openHABianPi:/usr/share/openhab2/addons $ ll
insgesamt 195M
drwxrwxr-x+ 2 openhab    openhabian 4,0K Aug  4 10:39 ./
drwxr-xr-x  4 openhab    openhab    4,0K Feb 10  2021 ../
-rw-rw-r--  1 openhabian openhabian 191M Feb  3  2022 openhab-addons-2.5.12.kar
-rw-rw-r--  1 openhabian openhabian 4,6M Jan  9  2020 org.openhab.io.homekit-2.4.0.jar.bak
-rw-r--r--  1 openhab    openhab      70 Jan 27  2021 README

Also cleaning the cache after uninstalling doesen´t help.

openhabian@openHABianPi:/usr/share/openhab2/addons $ sudo systemctl stop openhab2.service
openhabian@openHABianPi:/usr/share/openhab2/addons $ sudo openhab-cli clean-cache
openhabian@openHABianPi:/usr/share/openhab2/addons $ sudo systemctl restart openhab2.service

I did this two or three times… but it is still the same as before…
I also tried to rename the homekit.cfg to homekit.cfg.bak in Services so that OH2 is not reading the config file…