Homekit - Everything is breaking more everyday

Hi,

I am getting so frustrated with this.
It took me ages to get Homekit working, took me even longer to get the iOS Shortcuts/OpenHAB functionality working.
Since then, everything has been breaking one by one and I can’t get anything working again. I feel like I’ve gone right back to square one so many times, and followed so many different forum posts, but nothing is working.

My OpenHAB system is otherwise running perfectly without any other issues.

Can someone please walk me through this step by step because I’m going mad trying to figure this out.

Firstly the iOS Shortcuts stopped working one day with no changes made by me. I was never able to get this working again. I have started and posted in multiple forum threads with no success.

Recently all items became ‘Unavailable’ in the Home app. Nothing I did would make it come back. I then tried to remove and re-add the items, even though this is a massive PITA to rename and organise items in the Home app. But I can’t even re-add openHAB to the Home app now.
I get the message ’ This accessory is already added. To add this accessory to your home, you must reset it first’ - Even when I change the port, Pin, and Setup ID.
So now nothing is working!!!
I reinstalled the binding and tried every possible combination of options.

This should not be this difficult. Please help.
I have just installed OpenHAB 3.3.0.M6 in the hope there would be some fix or update but no luck.

Running on Pi4 in Docker container.

Sorry, don’t have too much to offer, but could it have something to do with your docker setup? I’m on OH 3.3.0.M6 on rpi4/openhabian-bullseye and the homekit functionality is rock solid even through version and OS upgrades. Literally set it and forget it.

the root cause for “Unavailable” is usually

  • network issues, i.e. home app / ios device cannot access openhab via mDNS service or using connection on homekit port 9123. this often linked to docker blocking the port or router blocking multicast
  • additional homekit bridges like ipad, apple tv or homepod, which are got disconnected or in sleep mode

so, typically this can be solved without re-adding or repairing.

first we need to fix you pairing. look like you have removed openHAB from ios home app.
in order to do so,

  1. in case you have apple tv, homepod or ipad, disable homekit bridge there
  2. login to karaf console
  3. openhab:homekit clearPairings

afterwards pair device again

  1. add accessory in home
  2. scan bar code in openHAB ui
  3. you should get all items visible and working in home app

unfortunately you need to renamed, group items again and add to shortcuts. do it first when everything is working again as expected.

as last step enables bridges in apple tv, homepod or ipad

Thanks guys,

clearPairings in karaf allowed me to readd my items to Home app.
I had to rename and reorganise everything again though, which is no fun.

I still can’t get iOS Shortcuts to load the items though. It just hangs forever.

My Docker setup on my Pi4 shouldn’t be blocking any ports. I have it in host network mode.

check list

  • do you see your items in home app?

  • can you control them or you still see “no response”.

    • if you see no response it is with 90% chance a network issue. it is no only about port but also about multicast/broadcast
  • do you have any apple tv/homepod or ipads at home? please make sure you have deactivated the homekit bridge there. you can activate them later, once you have stable setup

Thanks for your reply.
I got my items to show in the home app again by clearing the pairings described above.

However, I still can’t get iOS shortcuts working.
Do you know how to troubleshoot this?

1 Like

if the accessories are working as expected in home app then they should also work with shortcuts… the only idea i have - restart iphone and re-create shortcuts

1 Like