HomeKit Integration not accepting clients

I am running the openHABian release build 2.3.0 on my Raspberry Pi 3 for about 2 weeks or so, to get a feel for how it works compared to Domoticz. For this setup I kept it simple with just a few Hue lightbulbs and 2 z-wave devices, mapped to a hand full of items.
Next step for me is to get HomeKit Integration working so I can use Siri to control things using my voice.
I configured my items using a text file in the “items” folder, which provides more options than the Paper UI does.
This is my items file:

Group   Huis    	"Ons huis"              <house>
Group   BG      	"Begane grond"          <groundfloor>   (Huis)
Group   BG_Woonkamer    "Woonkamer"             <sofa>              (Huis, BG)

Dimmer               BG_Woonkamer_Lamp1             "Lamp1"               <light>         (BG_Woonkamer, gLicht)             ["Dimmable"]            {channel="hue:0100:00178869aabe:4:brightness"}    
Dimmer               BG_Woonkamer_Lamp2             "Lamp2"  			  <light>         (BG_Woonkamer, gLicht)             ["Dimmable"]            {channel="hue:0100:00178869aabe:5:brightness"}
Dimmer               BG_Woonkamer_Lamp3             "Lamp3"   			  <light>         (BG_Woonkamer, gLicht)             ["Dimmable"]            {channel="hue:0100:00178869aabe:6:brightness"}
Switch               BG_Woonkamer_WCD1              "WCD"                 <poweroutlet>   (BG_Woonkamer, gWCD)               ["Switchable"]          {channel="zwave:device:3e8cec06:node3:switch_binary"}
Number:Temperature   BG_Woonkamer_Temperatuur       "Temperatuur"         <temperature>   (BG_Woonkamer, gTemperatuur)       ["CurrentTemperature"]  {channel="zwave:device:3e8cec06:node2:sensor_temperature"}
Number               BG_Woonkamer_Luchtvochtigheid  "Luchtvochtigheid"    <humidity>      (BG_Woonkamer, gLuchtvochtigheid)  ["CurrentHumidity"]     {channel="zwave:device:3e8cec06:node2:sensor_relhumidity"}

DateTime         Sunrise_Time       "Sunrise [%1$tH:%1$tM]"     { channel="astro:sun:home:rise#start" }
DateTime         Sunset_Time        "Sunset [%1$tH:%1$tM]"      { channel="astro:sun:home:set#start" }
Number:Angle     Azimuth            "Azimuth"                   { channel="astro:sun:home:position#azimuth" }
Number:Angle     Elevation          "Elevation"                 { channel="astro:sun:home:position#elevation" }

Group:Dimmer                            gLicht              "Lampen"                <light>             (Home)      ["Dimmable"]
Group:Switch:OR (ON, OFF)               gWCD                "WCDs"                  <poweroutlet>       (Home)      ["Switchable"]
Group:Number:Temperature:AVG            gTemperatuur        "Temperatuur"           <temperature>       (Home)      ["CurrentTemperature"]
Group:Number:AVG                        gLuchtvochtigheid   "Luchtvochtigheid"      <humidity>          (Home)      ["CurrentHumidity"]

As per the wiki I installed the “HomeKit Integration” add-on and assigned tags to the HomeBridge compatible devices (lights, switches and thermostats basically).
Now that the configuration is done, I tried adding openHAB to my iPad Woning app, but failed when trying to pair after entering the code.

This is what I tried after it failed:

  1. Reboot
  2. Update & upgrade of packages
  3. SSH into the Pi and use the console to clear possible existing homekit pairings
  4. Used openhabian-config to check and fix permissions
  5. Used openhabian-config to apply all fixes and improvements
  6. Change the PIN in the HomeKit configuration (using Paper UI, not file)

The openHABian log (the one accessible via the 8080 webpage) does not show any errors or interesting messages, just state changes of sensor and so on.
So far nothing has helped and I still can’t connect to the Homebridge. I am out of options that I can think of or find on the forum.
Is there anyone here who can point me in the right direction, something I might be missing?

Note: tried 2 iPad’s. One with iOS 10.3.3 and one with 11.4.1.

Sorry I can’t help with your issue, no HomeKit or ipad, just wanted to thank you for the detailed post. All the info you can provide on the first post makes it both quicker and easier to get help, as well as help others.

Thanks again, I’m sure someone here will be able to assist.

1 Like

Thank you and yes, I hope there’s someone out here who knows what can be wrong.
One thing I forgot to mention is that I also tried to reinstall the add-on, obviously without the desired effect…

I noticed that my homekit.json config file was empty, besides to curly brackets: { }.
To clear it out, I stopped openHABian and removed the file, then started openHAB again.
Still nothing is mentioned in the log files regarding homebridge/homekit.
Why is this such a pain to get working :disappointed_relieved: