HomeKit Integration not working

I have struggled to get HomeKit working in my OH 2 installation. In one of my previous installation of OH 2 I tried using the OH 2 with no luck at all. A week ago I did a clean installation of OH 2 (using apt get), hoping that it would clear things up and make the HomeKit integration run properly. After fiddling with the settings of the HomeKit integration via Paper UI I did manage to make OH appear as a HomeKit bridge on my iPhone. The names of my hue lights did not transfer properly, so after linking all items up with the correct channels in OH, I deleted the bridge from HomeKit, and then tried to add it to HomeKit again - but the OH bridge never appeared again. The log makes no mention of the HomeKit integration though it seems to be installed via Paper UI. Have of course tried uninstalling and reinstalling the integration (through Pater UI).

Any suggestions on where I might look to find answers would be highly appreciated!

I’m running OH 2 an a Raspberry Pi 2.

BTW This is my first post, so please let me know if I things are unclear.