[homekit] "No response" error on all openHAB items

I had problems between the end of April until last weekend. Since my openHAB installation was not updated during this period, I strongly believe that the problem was caused by an OS update. The problems started after I received an OS update and disappeared after another one. So my understanding is that the problems should be independent of openHAB and a router. It’s just a guess, but updating the OS as soon as possible can’t be wrong. I appreciate feedback if anyone has had the same experience.

openHAB 3.0 and binding have upgraded the mDNS library. new version library has fixed some issue, but maybe added new once.
one of the most prominent is that one, which got fixed 9 days ago (but not released yet)

but it could something else. in general, homekit binding has not changed that much from 2.x to 3.x

I used a old iPad Air as HomeKit hub - was pretty slow. If my iPhone was connected to the network the phone pulled states directly from openHAB so this was faster. I don’t have any problems since my HomePod mini arrived: its always on and fast.
I don’t have experience with MacBook or AppleTV.

1 Like

I just updated today to the last stable 3.1.0 docker Version of openHAB, but still having the issue, that after a clean startup of openHAB HomeKit is not working. So I have to enable / disable “Use openHAB mDNS service”, then everything is running fine. I have no errors in the log file. Am I the only one with that problem?


multiple users have reported similar issue in combination docker with ipv6. disabling ipv6 support at docker level solve this issue for many.

So there won’t be a fix for that problem? Does someone has it working with ipv6 disabled in Docker only? And how did you configure that?

I did it that way:
Creating that file /etc/sysctl.d/10-disable_ipv6.conf with:


to enable without rebooting the system use this command on the Linux Shell:

sysctl net.ipv6.conf.all.disable_ipv6=1

Then I created the /etc/docker/daemon.json with that configuration:

  "ipv6": false

After systemctl restart docker It seems that HomeKit is working without switching mDNS Option on and off.

1 Like

I don’t use Docker but I had issues that past two months. Sometimes it worked for a longer time, then it I had issues every two three days. In any case that is not reliable as I use HomeKit for some automation task like presence detection.

I have now successfully disabled ipv6 following How to disable IPv6 in Raspbian [WORKING] – CWESystems and will keep you posted.

I am having the same issue. Don’t use docker as well. I also have a hue bridge in the same network which is always visible in the discovery app (_hap._tcp dmain). The OpenHab entry disapears some time after the restart of openhab or just the bundle (bundle:restart ).
Due to the fact that the hue bridge is working, I would eliminate problems with a wrong configured access point. If OpenHAB is visible in the discovery app, it shows the IPv4 address.

I‘m facing a similar issue since I updated to OH 3.1 stable.
With the previous 3.1.0Mx releases I didn’t see the behavior. Maybe it’s by coincidence only.
Every time my internet connection is down, the HomeKit doesn‘t work anymore.
Bundle restart does not solve the problem anymore.
Something has changed, but not sure what.

Update: I get it work again by toggling the option

„Use openHAB mDNS service“

I saw the same issue yesterday after I had also an offline internet connection. Before that offline issue everything worked well for weeks. Also on openHAB 3.1 and I had switched the mDNS Switch on and off again, too. After that it worked again.

I have the issue again, but neither toggling nor bundle restart does help this time.

Seems I have to remove the OH from Homekit and re-add it again.
This always worked the last time…

Any other idea?

Many thanks.

hmm. strange. any error in OH logs?

try to restart OH completely or even docker container if you use one.

as long as the mac address of the device (iphone) does not change there should be no need to re-pair/re-add it.

Same here.

After the move from 3.1M5 to 3.1 all HomeKit devices where offline, also those directly working with HomeKit.

Removing OH from HomeKit and re adding the devices worked.

I did this already. I deleted the old docker container and installed it again.

I cannot see any errors in the logfile.
Does it make sense to trace something?

if you have access to openhab karaf console, you can try to increase log level with

log;set TRACE org.openhab.io.homekit
log:set TRACE io.github.hapjava

All my items were “No response” too.
Solution for me was removing my ‘home’ from the Home app and then readding OpenHAB bridge.

1 Like

How’s your setup since removing and re adding everything? Mines been dropping out still

What seems to work for me is an iPhone reboot, then all items respond again.

I have also had the problem that every few days all HomeKit devices show ‘no response’.

In my OH logs I found the following exception:

22:48:50.966 [WARN ] [javax.jmdns.impl.tasks.Responder     ] - Responder(*snip*)run() exception
java.io.IOException: Operation not permitted
        at java.net.PlainDatagramSocketImpl.send(Native Method) ~[?:?]
        at java.net.DatagramSocket.send(DatagramSocket.java:695) ~[?:?]
        at javax.jmdns.impl.JmDNSImpl.send(JmDNSImpl.java:1665) ~[bundleFile:3.5.7]
        at javax.jmdns.impl.tasks.Responder.run(Responder.java:154) [bundleFile:3.5.7]
        at java.util.TimerThread.mainLoop(Timer.java:556) [?:?]
        at java.util.TimerThread.run(Timer.java:506) [?:?]

After looking into the code of jmDNS I changed the following line and I have no issues since then.

A pre-built JAR file with the fix can be downloaded here: Dropbox - jmdns-3.5.7.jar - Simplify your life

Replace it with the original jmdns-3.5.7.jar. If you’re using docker, mount the JAR under /openhab/runtime/system/org/jmdns/jmdns/3.5.7/jmdns-3.5.7.jar

I suspect the exception is triggered by a mDNS message sent by one of my other devices on the network. After the exception occurs the OH jmdns client is stopped.

If other people can confirm this solves their ‘no reponse’ problem as well, I will create a pull request to jmdns.

1 Like

I am experiencing the same problem (openHab devices with „no response“ in Apple Home app). In my case

  • toggling the mDNS-switch in HomeKit-Integration of openHab or
  • even a restart of openHab

does not heal the issue.

Is anybody able to confirm that replacing jmDNS with the updated version of @erikvdv1 does fix the problem?