Homekit not discovering one particular z-wave node (solved)

Running Openhab 2.1 on RPi3, and loving it so far. I have 16 Z-wave nodes working great in the Paper UI Control tab. I have the Homekit service and it works amazing except it will not recognize one particular z-wave node. The light in my home office. It is the one particular node I tried starting to control with Homekit a week ago as it is in the same room of the computer I use to configure Openhab with so it is easy to see if it is being controlled. Not sure if I did something to make Homekit want to ignore it. I have tried deleting the item and remaking the item and deleting Openhab from Homekit and discover again with no luck, I then tried deleting the thing for that node and renamed the thing study instead of office and made a new study item. I added the Lighting tag just like all the other dimmers that do work. I checked my homekit.cfg file and I have nothing in there about the node that might make Homekit ignore it.

If anyone might be able to help I would surely appreciate it.

Thanks in advance


I tried adding another item totally unrelated to the z-wave node. And it shows up in paper UI but it is not showing up in Homekit either, and it is an identical copy of one that was there originally with the tag Switchable just with a different name. So my Homekit just apperas to keep “rediscovering” only the items it found originally. How do I get it to discover the items that have been added or changed? Thanks

Update 2:
I rebooted the RPi and then I also removed the “Home” from Homekit and then on discovery it found my 2 items.

Hope this helps someone out.