Homekit OH3 - strange

I’m desperately trying to connect HomeKit right now, unfortunately without success.

I have configured my items, when I search for new devices with my iPhone XS I immediately find a device “openhab”. After adding it, all items tagged in openHab are created - so far so good!

Now when I open my tablet all devices are not accessible. After about an hour I have the same problem on the iPhone. Then I have to delete the bridge in the Home APP again and add it again - including mapping the rooms etc… With almost 100 items, that’s a bit exhausting.

In addition, I have the following messages in the log, I use Homematic thermostats:

2021-01-14 19:34:03.287 [WARN ] [al.accessories.HomekitThermostatImpl] - Unrecognized heatingCoolingCurrentMode: AUTO-MODE. Expected CoolOn, HeatOn, or off strings in value.
2021-01-14 19:34:03.291 [WARN ] [al.accessories.HomekitThermostatImpl] - Heating cooling current mode not available. Relaying value of OFF to Homekit

I have clear all Pairings in Karaf-Console and tested again - without Success. The strange thing is, that my iPad dont find the openhab Item in Home-App. Only my iPhone find it.

iPhone XS: iOS 14.3
iPad: iOS 14.2
Both devices use the same WLAN with the same iCloud Account.

I have no idea anymore i hope you can help me :slight_smile:

Hello,
It works flawlessly for me for about 24-48 hours, then stops again :frowning:
You need to restart the homekit addon from Console
bundle: restart PID <- Homekit binding.
And again a good 24-48 hours.

To re-pair:

 Delete pairing from the IOS home app
 openhab-cli console - >> smarthome: homekit clearPairings
 smarthome: homekit allowUnauthenticated true
 Uninstall Homekit Integration (WEB)
 sudo rm -r /var/lib/openhab2/jsondb/homekit.json
 Install homekit integration addon and configure
 Restart openhab.

I have performed the steps, unfortunately without success. I still can’t find the openHab base on the iPad. When I add the base on the iPhone, all devices on the tablet are not accessible.
What else can I do?

the sync between the devices is kind of magic. i could not find any apple documentation for this.
but your ipad/apple tv or homepods can act as a bridge between different devices. you can see it in the settings of the device.

i have both - ipad and apple tv. i had some issues back in the time as my ipad was the bridge. after i have disabled the bridge on ipad it works without any single issue for more than a year now.

try to disable and enable homekit bridge on your device and see whether it makes any difference

Thanks for your message. I cannot find this setting. Can you explain me where I can find it?

Here some pictures.

The second picture is from the tablet.

You have to go to your iPad general settings.
There you will find under the Home settings the option to enable or disable the iPad as a HomeKit hub.

The option was off. The iPad wasn’t a HomeKit hub. Do you have more ideas what I can do to use HomeKit on the tablet :confused:

PS: I Shared the Home with my wife’s iCloud account. On her iPad and her iPhone all works fine. Only my iPad doesn’t work.

Some time ago I had the same problem with my Mac.
All devices worked without problems, even the invited ones. Only my Mac showed „not responding“ and was out of sync.
Logging out of my iCloud account an logging in again after a few minutes solved it for me permanently.

I tested it too. But without success. I logged out and in again. But all items showed „not responding“ it’s strange.