Homekit Service just stops working

homekit
Tags: #<Tag:0x00007f6cefe90828>

(Markus Gevers) #21

I'm running into the same issues. Has anybody found a solution yet?

I now disabled ipv6, we'll see ...


(Stefan Danz) #22

For me it didnt work out....I hope I really stopped ipv6, but Homekit still stops working.

no solution for me so far.


(Markus Gevers) #23

Seems to work here for three days by now.


(Stefan Danz) #24

Maybe you can describe exactly how you did disable ipv6. Maybe there is a difference (for me at least). Up to now, still my homekit stops working every day. For me it seems to be connected to the presence "inhouse" of the homekit device iphone and/or ipad.


(Matthew Fogle) #25

If this is the same problem I'm seeing, every day to every couple days (unsure of a pattern at this time) Openhab2 entirely become unresponsive. The zwave controller and items all appears online, but no changes are pushed. The zwave binding fails to log ANYTHING to the log. And all this follows the same java exception crash pasted above. Somehow Homekit is killing openhab...


(Richard Lee) #26

Anyone made any progress on figuring this out? It just stops after having worked for a while. Restarting openhab doesn't fix it. I have to clear the pairings and re-configure them all to get it working again, which is a real pain.


(Stefan Danz) #27

Not me :confused:
The only thing is, that a restart of the bundle via karaf is working. so no need (at the moment....) to restart the whole OH service. But the rest is still as it was before :frowning:


(Stefan Danz) #28

Are you still handling the homekit things, @beowulfe ?

I am still in the same problem hoping for new release via snapshot, but I believe the development stopped somehow. Would it make sens to raise an issue? Or is it useless?

I still in need to get this working :frowning:

br
Stefan


(Stefan Danz) #29

Just a short update on this bad behavior:

I installed a week ago BlueZ 5.45 and from then my HomeKit Service works without any problems!


http://www.bluez.org/download/

I changed to things with this:
1. Update to 5.45 from 5.43
2. I did NOT use "--experimental" as mentioned in the installation instruction, but standard

pi@raspberrypi3:~ $ sudo systemctl status bluetooth.service 
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since Sa 2017-07-01 06:00:07 CEST; 4h 21min ago
     Docs: man:bluetoothd(8)
 Main PID: 3689 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─3689 /usr/local/libexec/bluetooth/bluetoothd

Jul 01 06:00:07 raspberrypi3 systemd[1]: Starting Bluetooth service...
Jul 01 06:00:07 raspberrypi3 bluetoothd[3689]: Bluetooth daemon 5.45
Jul 01 06:00:07 raspberrypi3 bluetoothd[3689]: Starting SDP server
Jul 01 06:00:07 raspberrypi3 systemd[1]: Started Bluetooth service.
Jul 01 06:00:07 raspberrypi3 bluetoothd[3689]: Bluetooth management interface 1.14 initialized

Didnt notice that bluetooth restarts at 06:00 AM ? but anyway, at the moment this combination works as expected!!!

Maybe it will help others as well.

br
Stefan


(Golan cohen) #30

I'm not sure how but I think this also fixed my problem. Thanks!


(Jeremy Ellison) #31

I’m also experiencing this issue. It appears to happen whenever my router reboots (so the pi drops offline and comes back). bundle:restart xxx does fix the issue.

I’m really confused at how installing bluez would help. Doesn’t seem to make any sense. Homekit is all over Wifi, right?