Homekit Setup

i have the same issue. A workaround is to define the inbox detected item again in the .items file. That works for me but is a hack while investigating how to add the require (“Lighting”) tags etc via the GUI.

For me it works, if I use the HABmin UI. During the creation of an item from a thing (section channels), I can add the “Lighting” or “Switchable” Tag.

Re-Adding items OH1 way made the items controllable from homekit. But this is a shortcoming that has to be sorted out. A simple field on the paper UI should do the trick.

Does anyone have a working config for the release version of OpenHAB 2.0 ? My phone sees the openHAB accessory but nothing happens when trying to add it after entering the PIN

I don’t see any log entries from the homekit addon when the phone tries to connect, but while loading openHAB it does output about 30 repeated lines like these:
2017-01-27 20:32:25.986 [INFO ] [com.beowulfe.hap.HomekitRoot ] - Added accessory null
2017-01-27 20:32:26.006 [INFO ] [pl.http.impl.NettyHomekitHttpService] - Resetting connections

I thought it would just ignore items that didn’t have the correct tags assigned, it almost seems like something gets stuck trying to parse my item configs? Should I see any output from HomeKit about the items that have the Switchable tag assigned while starting up?

For the love of me, but I can’t understand how am I suppose to configure homekit. Where is the “tag” field I should put “lightning” in?

You have to define the tags in the item definition textfile for now, HABmin can show them but can’t edit them. The syntax is here http://docs.openhab.org/configuration/items.html#item-syntax

itemType itemName “itemLabel” (itemGroup) [“itemTag”] {bindingconfig}

Note that the order is important, i tried modifying an old item by sticking the tag block after the binding block but that confuses the config parser.

I finally got my iPhone to pair with OpenHAB today by disabling simple mode item linking in Paper UI and following the instructions from this post: Unable to discover openHAB2 with Homekit (iOS 10)
Beware that this will reset your configuration completely except for what is defined through the classic text files.

I think the HomeKit binding probably got stuck trying to parse all mye Hue lamps that had the Lighting tag, and my Hue hub has direct HomeKit support anyway so I don’t want OpenHAB to present those twice.

@ssvenn that much I got but I can’t find an item definition file on my whole machine. The items folder just contains a “readme”. And yes, it’s the same for me in habmin, the text field is disabled.

actually I facing same issue when I link to homekit,
I found most of issue can sort by restart openhab, sometimes I think restart machine will necessary in few circumstance
once the Tag [Lighting] in items in correct positions, home kit should able to show up the devices. in my case, homekit able to show the devices status in instance (like you turn on/off device by other method and homekit will indicate it’s on/off) but not able to control, homekit think it’s changed the status but it’s not, issue solved by restart openhab.

so I suggest you keep restart openhab once setting have changed

you can make tag in habmin or you can delete the items which create by paper ui and manually create a file call xxx.items in items folder by txt editor, items create by Paper UI stored in .db in difference location.

You have to create it :slight_smile:

If you are unfamiliar with the old openHAB 1.x way of doing things, go grab the demo setup package from http://www.openhab.org/downloads.html to have some examples to study. There’s also lots of information in the old bindings wiki.

Any binding that has a new 2.0 version will need to be configured as { channel=“binding:instance:detail” } , if you go look at the Things listing in Paper UI it will show you the correct syntax and you can copy and paste that into your items text file.

openHAB 2 does not maintain the old text files for you when you make changes through the GUI, the “new” item link configurations done through Paper UI and HABmin end up in /var/lib/openhab2 while the “old” style configuration files end up in /etc/openhab2/ - and there’s also a /usr/share/openhab2 for installing non-bundled bindings.

It’s confusing to have the config in three different locations but it was probably the only reasonable way to keep clean backwards compatibility.

I’ve shared the three directories through Samba on my openHAB linux server so that I can mount them on my mac and run Eclipse Smarthome Designer there to get a nicer editor.

How can I set the tag in habmin?

Configuration > Things > the thing you need to set eg: ABC > Right hand side Channel > Below Linked itmes have an icon in blue, click that

@hamwong it works, you are a gentleman!

i do as all other here will do, I just learn how to setup openhab in 2 months ago and I get help from all gentleman here.

Thanks, I was unaware of that method. The fields are read-only in the HABmin Items list but not in the Things list!

That saves me from a lot of text-file editing, I just tested it and it works great with HomeKit :slight_smile:
It looks like the HomeKit binding tries to add new Accessories as soon as they are tagged but they don’t actually show up on my phone until I either restart openHAB or the binding.

if you just a quick shot or only few items to controll, this is a way to go and you only do control on homekit,
otherwise, you may still need to do the text way as you can’t define Group in GUI way, if you got lot of items to control, group management is better way to go.

a few days ago I started with homebridge and openhab1. I managed to make them work, I am able to control items from openHab using Siri. But in config.json I have added as “customattrs” only 2 items (just for testing purposes), but homebridge added all items that could be found on openhab (like 70) and so I have them all on my iPhone and I don’t need them.
How the configuration should look like in order to have only the desired items from OpenHab in Homekit?

I am stuck, confused and need help.

I’ve dug through the forums here, but I can’t seem to find a single document showing how to setup the HomeKit integration step by step (in a brand new installation).

I installed the binding, configured it. Created an items and sitemap file manually (proper order as mentioned earlier here in the thread).

But it seems that the moment I try to add an accessory on my iphone - I see in the log that a new connection is made and almost immediately dropped, as shown below:

21:44:39.102 [INFO ] [.hap.impl.http.impl.AccessoryHandler] - New homekit connection from /
21:44:39.105 [TRACE] [pl.http.impl.NettyHomekitHttpService] - READ UnpooledUnsafeDirectByteBuf(ridx: 0, widx: 125, cap: 1024) [/]:
00000000 50 4F 53 54 20 2F 70 61 69 72 2D 73 65 74 75 70 POST /pair-setup
00000010 20 48 54 54 50 2F 31 2E 31 0D 0A 48 6F 73 74 3A  HTTP/1.1..Host:
00000020 20 6F 70 65 6E 48 41 42 2E 5F 68 61 70 2E 5F 74  openHAB._hap._t
00000030 63 70 2E 6C 6F 63 61 6C 0D 0A 43 6F 6E 74 65 6E cp.local..Conten
00000040 74 2D 4C 65 6E 67 74 68 3A 20 36 0D 0A 43 6F 6E t-Length: 6..Con
00000050 74 65 6E 74 2D 54 79 70 65 3A 20 61 70 70 6C 69 tent-Type: appli
00000060 63 61 74 69 6F 6E 2F 70 61 69 72 69 6E 67 2B 74 cation/pairing+t
00000070 6C 76 38 0D 0A 0D 0A 00 01 00 06 01 01          lv8..........

21:44:39.110 [INFO ] [ulfe.hap.impl.pairing.PairingManager] - Starting pair for openHAB
21:44:42.434 [INFO ] [ap.impl.http.HomekitClientConnection] - 200 /pair-setup
21:44:42.439 [TRACE] [pl.http.impl.NettyHomekitHttpService] - WRITE UnpooledUnsafeDirectByteBuf(ridx: 0, widx: 512, cap: 512) [/]:
00000000 48 54 54 50 2F 31 2E 31 20 32 30 30 20 4F 4B 0D HTTP/1.1 200 OK.
00000010 0A 43 6F 6E 74 65 6E 74 2D 74 79 70 65 3A 20 61 .Content-type: a
00000020 70 70 6C 69 63 61 74 69 6F 6E 2F 70 61 69 72 69 pplication/pairi
00000030 6E 67 2B 74 6C 76 38 0D 0A 43 6F 6E 74 65 6E 74 ng+tlv8..Content
00000040 2D 4C 65 6E 67 74 68 3A 20 34 30 38 0D 0A 43 6F -Length: 408..Co
00000050 6E 6E 65 63 74 69 6F 6E 3A 20 6B 65 65 70 2D 61 nnection: keep-a
00000060 6C 69 76 65 0D 0A 0D 0A 06 01 02 02 0F 69 B3 6E live.........i.n
00000070 55 7D 4D CC AD 03 4A 18 B2 EC 89 DE 03 FF 44 A1 U}M...J.......D.
00000080 B7 07 F1 C8 30 1F EB BE 67 C3 87 D0 9A C9 6C C5 ....0...g.....l.
00000090 79 14 E0 88 B5 14 15 37 D9 41 C9 BC 53 99 CF 19 y......7.A..S...
000000A0 B9 FE 2E C6 1D AA C4 71 2B 8B 67 98 25 3E F2 AD .......q+.g.%>..
000000B0 98 DD C1 B6 52 78 90 5A 32 D3 F6 4D 7D 0E 20 18 ....Rx.Z2..M}. .
000000C0 F4 07 AE 44 E7 B9 CF 3D 31 50 E1 D4 8B F1 02 9F ...D...=1P......
000000D0 10 89 BA 1E 4E 31 6E 4D 01 A1 1A 9E 55 14 33 7F ....N1nM....U.3.
000000E0 4C BD DD 67 A7 FC 52 0C B8 D7 20 BA 03 4D 10 E3 L..g..R... ..M..
000000F0 FD 27 41 1C 10 2E 25 EA F6 5F 59 EF 60 01 46 E5 .'A...%.._Y.`.F.
00000100 33 21 D7 50 B5 F2 A9 5E FC A1 46 29 46 8A 02 A6 3!.P...^..F)F...
00000110 5F D7 66 DF 45 22 57 D4 6B CA 13 80 AE 7A BC 98 _.f.E"W.k....z..
00000120 A1 18 13 73 D0 F0 8B 39 1F E4 AF 4D ED FD 3A F1 ...s...9...M..:.
00000130 34 70 A0 4C 96 32 BA 7D C3 25 41 88 07 F2 10 49 4p.L.2.}.%A....I
00000140 53 71 9A 6D 74 77 F9 CD 6E D4 CF 2B EF 0B 0A 0B Sq.mtw..n..+....
00000150 2B 8A 90 76 12 84 8F 84 FA 9E 84 70 FB A5 17 CC +..v.......p....
00000160 CD D5 49 C3 09 23 5E 2E EF 6C 25 55 29 7F EA 5C ..I..#^..l%U)..\
00000170 21 E9 B5 3E FF 18 5C C9 CC 22 1F DD A3 03 81 7F !..>..\.."......
00000180 76 00 83 17 65 1A 8B B6 C9 D1 C8 06 65 0C 95 8E v...e.......e...
00000190 7C 7E D0 A1 8F BC CE A9 41 47 1E 8F 74 68 59 F8 |~......AG..thY.
000001A0 5E 6A 87 36 98 2A 96 FA D7 60 B8 C8 CB D9 F0 27 ^j.6.*...`.....'
000001B0 69 AB DE 38 2E 68 89 E5 BA 23 C7 23 5E CE C6 9D i..8.h...#.#^...
000001C0 15 1B B1 D4 D7 15 6D 18 39 B4 85 08 EB 2E E1 BC ......m.9.......
000001D0 4B 49 2A 76 3D 90 84 EC 07 E3 2E 11 46 53 A6 A6 KI*v=.......FS..
000001E0 02 F2 0A 4F 26 47 B6 17 FE 58 8B A0 D0 34 0A CF ...O&G...X...4..
000001F0 98 FA 1C 7D 5C 7A 98 4C C6 F5 AD 83 EE 1E 46 9D ...}\z.L......F.

21:44:42.524 [INFO ] [.hap.impl.http.impl.AccessoryHandler] - Terminated homekit connection from /

This is even before the iphone asks me if I want to type in the code manually.

My items file:

Switch hkLRoomLightSwitch "LRoom Light" (LRoom) [ "Lighting" ] { channel="zwave:device:AeotecUSBZStickGen5:node14" }

Sitemap file:

sitemap homekit label="HomeKit" {
    Frame label="HomeKit" {
        Switch item=hkLRoomLightSwitch label="Living Room" icon="light"

Has anyone had a problem like that?
Or maybe there’s a simple step by step guide I can follow to try to set it all up?

Have the same problem as you @SFXFreak
And no clue what to do …

I believe this has been broken in newer iOS releases. I’ve tried 100 different ways to get this working with no luck.