HomeKit stops responding after a day

Each morning for the past two days I’ve noticed that HomeKit stops responding and requires a restart of openHAB. Any ideas about what might be causing this?

Is there a way to enable debug logging for HomeKit?

Still happening, every day, even sometimes multiple times per day.

I have the same problem…also no answer yet :frowning:

You can enable debug logging, even in a separate file to make it more visible. BUT: for me it doesnt help, because it just stops. I “terminates” the conection and thats it. Then it continues “publishing changes” but looking into Homekit APP just informs that OH is not available :frowning:

in the console

ssh openhab@localhost -p 8101

PW: habopen

you can set the log level for the bundle, and you can restart the bundle (bundle:list note the Homekit number and do a bundle:restart NUMBER) so at least you dont need to restart the whole OH2 server

But at the end of the day, it is no cure :scream:

I hope you fixed it in the meantime :slight_smile:

the same issue started happening to me, running OH3. i could not figure the reason for it. nothing in the logs about Homekit.

is anyone experiencing this? and possibly found the root cause ?

Me too! At first i thought it has something to do with the null-state of the item but my homekit does not respond either after some time.

Also using OH3.

Maybe same problem:

Same here. Worked until OH3M4 I think.

Is anyone here running Unifi APs? Try that.