Homematic Binding --> Jetty start failed

  • Platform information:
    • Hardware: Intel Core i5-4300M, 16 GB RAM
    • OS: Windows 10 Professional (v1903 + v1909)
    • Java Runtime Environment: Zulu (64 Bit)
    • openHAB version: 2.5 M2
  • Issue of the topic: After a Reboot of my Windows machine all of my environment is working fine except the Homematic Binding and all related items/rules. I tried several things incl. backups but none of them worked. Today I performed an Update to 1909 but also after uninstallation the error still occurs.
    I tried to update to 2.5 stable which was not succesful. In case of Homematic I do a clean new installation and just added Homematic with the same behavior. No other things were changed. All of my stuff is reachable in my network and its not working at all.

I checked several google hints but none of them were working so I am really lost because my motion sensors and other stuff is not working yet.

Which log can help to figure it out?

1 Like

I do not know, but perhaps updating to the stable 2.5 version would help. Milestone 2 was release last August, I believe as a Test build for 2.5 Stable.

thanks for the quick response but this is what I already tried. I have disabled my current installation and installed the stable 2.5 in a separate folder. I did the initial setup and just added the Homematic Binding. The CCU (Bridge) was auto-detected instantly. After adding it the same error occurs instantly. I did not get access to it.

The last from the log:

17:43:23.972 [INFO ] [nternal.communicator.client.RpcClient] - Interface ‘WIRED’ on gateway ‘3014F711A0001F98A99A2566’ not available, disabling support
17:43:25.994 [INFO ] [nternal.communicator.client.RpcClient] - Interface ‘CUXD’ on gateway ‘3014F711A0001F98A99A2566’ not available, disabling support
17:43:26.012 [INFO ] [communicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.49.17,address=PEQ1097062,rf=true,wired=false,hmip=true,cuxd=false,group=true]
17:43:36.069 [INFO ] [nternal.communicator.client.RpcClient] - Interface ‘WIRED’ on gateway ‘3014F711A0001F98A99A2566’ not available, disabling support
17:43:38.087 [INFO ] [nternal.communicator.client.RpcClient] - Interface ‘CUXD’ on gateway ‘3014F711A0001F98A99A2566’ not available, disabling support
17:43:38.106 [INFO ] [communicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.49.17,address=PEQ1097062,rf=true,wired=false,hmip=true,cuxd=false,group=true]
17:43:48.168 [INFO ] [nternal.communicator.client.RpcClient] - Interface ‘WIRED’ on gateway ‘3014F711A0001F98A99A2566’ not available, disabling support
17:43:50.188 [INFO ] [nternal.communicator.client.RpcClient] - Interface ‘CUXD’ on gateway ‘3014F711A0001F98A99A2566’ not available, disabling support
17:43:50.205 [INFO ] [communicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.49.17,address=PEQ1097062,rf=true,wired=false,hmip=true,cuxd=false,group=true]

Any idea?

Sorry, I do not use Homematic. or OH on Windows.

Really really strange. I have activated my old Openhab on my rpi3 and Homematic was direct working from this device.
So my CCU3 was not the problem. I checked more detailled logs from the Homematic Binding and set up a new IP address for my ethernet adapter which was not assigned before. I updated my thing and voila it is connected again!!!

You changed the IP-Address of openhab?