Homematic Binding not working (HmIP-WTH-2), getting error "not found on gateway"

dear community,

i have running current openhab 3.1 and my homematic is an raspberry pi 3 with raspberry matic 3.65.11.20221005).

i get always this error message in openhab:


in homematic the values all working fine, also nothing has changed in the configuration.

can anybody helps me what i can try to do?

thank you so much

many greets

Hi Markus,

are there any messages in openhab.log?

Are other HmIP devices working correctly? Do you have other thermostat devices?

Hi @MHerbst ,

no, i cannot found any errors in the openhab log.
only this message for each device:
[WARN ] [ernal.handler.HomematicBridgeHandler] - Device with address ‘000A9709904F69’ not found on gateway ‘3014F711A061A7D7098E12CB’

but some (same firmware + same hardware) are online and working in openhab.

but all working in homematic.

what i can try?

thank you so much

I has found the solution. after a restart from openhab linux system, all working well.
can i in any case restart only the “needed” services? when i create a script and got the same error messages in log, that i then can restart the service? thank you so much for your help

You can restart openhab with sudo systemctl restart openhab. It should also be possible to restart only the Homematic binding via a Karaf command. But I have never tried it from outside the Karaf console.

1 Like

Thank you so much for your help @MHerbst