Homematic Binding + OH 2.3 + CCU3 + Read timed out

Do you mean the Firewall settings? If yes, yes I added 8701 to Port Freigabe. I checked also the homematic Bridge at openhab and there is also 8701 as cuxd port. Any ideas? Thx for your help

By the way, I tried it with the nightly addon build 3102 because 3093 is not working anymore. Maybe this is the problem?! Can anyone of you share the link again? Thx and kind regards

Hey Marco, sorry i was very busy, my config works fine now.

Can I ask what you’ve done?

nothing but wait, the last days have not changed anything and it’s the ccu and all the devices are online

@Boogieman now I have updated OH2.4.0 build 1441 and it does not work anymore.

2018-11-23 21: 54: 28.259 [WARN] [ommunicator.AbstractHomematicGateway] - Connection on gateway ‘3014F711A0001F98A99A2C37’ interrupted, cause: “No pong received!”

After an OH reboot, it will work for some time and the connection has been lost.

it looks like,

As described/discussed in the topic Homematic CCU3 connection issues - COMMUNICATION_ERROR Unknown XML-RPC tag: title:

SOLUTION: the same config which doesn’t work on 2.3, works flawlessly on 2.4M6 after an upgrade by apt-get upgrade as described in the upgrade/installation manual

Hi @ComJack85,
did you find a solution for the problem? My bridge connects to my RaspberryMatic just fine, all things go online and the items update, so receiving data from the CCU is not an issue, but after about 35 seconds the connection always breaks down and all the things including the bridge go offline again.

My setup worked fine until last week when I updated from 2.3 to 2.4M6 and now 2.4M7. Initially I ran into an issue due to my thing configuration including a callbackHost. This was not working as I’m running openHAB in a docker container.
Bridge homematic:bridge:ccu [ gatewayAddress=“”, gatewayType=“ccu” ]//, callbackHost=“”, xmlCallbackPort=9125, binCallbackPort=9126 ]
Without the callback configuration the initial connection works perfectly, but breaks down… I don’t know what goes wrong, as communication back and forth obviously works (connection is initiated and data values come in from the ccu…).

Does anybody have a good idea how to resolve this?
Setting the docker container to network_mode “host” works, but breaks my setup due to other containers working in parallel (MariaDB, InfluxDB, MQTT etc.).
Is a callback into the container impossible?!

Hi had the same Problem with the CCU. I run a Raspberrymatic with and openhab2 2.3 on an PI. Than i moved openhab to the Docker Container and it worked fine. I got the HmIP-MP3P that requires the newest firmware but than I got the same issue as a both. openhab 2.4M7 wokred for me but my bridge is simpler included

Bridge homematic:bridge:ccu [ gatewayAddress="192.168.x.x" ]

@SymanK maybe you should try macvlan

Macvlan was a pretty great idea… I should have tried that before, it solved my problems!
Still, I would really like to understand what causes the issues when using the usual docker network bridge. I do not see the root cause, as the communication works perfectly fine until the connection is terminated.
Either way, thanks for your answer, ist got me on the right track :slight_smile: :+1:

Can’t get it to work no matter what. Always get
[WARN ] [ommunicator.AbstractHomematicGateway] - Connection lost on gateway 'xyz', cause: "No Pong received!"
Running the latest openhab 2.4 in a docker container and the latest raspberrymatic on a raspi3 with all relevant ports open.
Any input would be much appreciated.

Do you have authentication disabled as well?

Yes, authentication is disabled.

For future refference, if someone else experiences the issue:
It is fixed for me now. The problem was that callback IP is used for both binding to the interface and as the callback IP.
In my case it was only possible to bind to, which was obviously not working as the callback address.

The author provided a test version where bind and callback address can be assigned individually in the github issue . It works fine for me with that version.

1 Like