Homematic Bridge Offline after myOpenHab installation

I’ve installed a Homematic-Bridge successfully and everything worked fine. I could create things and items from Homematic devices and could control them as well from Openhab 2.4

Now I’ve installed openHab cloud in order to control my smart home from abroad. When I’ve opened Papier UI the first time from myOpenhab, I could see no Homematic items anymore - the bridge and the items went offline. The bridge says that jetty start failed.

Openhab.log looks like that:

2019-02-17 19:06:17.983 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2019-02-17 19:06:18.064 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
2019-02-17 19:06:18.347 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to '53.5781376,9.957376'.
2019-02-17 19:06:33.041 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'W88LabFullStack.rules'
2019-02-17 19:06:33.331 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2019-02-17 19:06:33.962 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'W88Lab.sitemap'
2019-02-17 19:06:36.411 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2019-02-17 19:06:36.415 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2019-02-17 19:06:36.931 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2019-02-17 19:06:37.361 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to '' with clientid paho46711633887 and file store '/var/lib/openhab2/mqtt/'
2019-02-17 19:06:51.809 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = e4d9cdc6-f2b9-48c7-aff4-ed6f6d11a2aa, base URL = http://localhost:8080)
2019-02-17 19:06:58.154 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'WIRED' on gateway '3014F711A0001F98A9A57FA6' not available, disabling support
2019-02-17 19:06:58.306 [INFO ] [ommunicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.41.11,address=PEQ1841062,rf=true,wired=false,hmip=true,cuxd=true,group=true]
2019-02-17 19:07:13.705 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'WIRED' on gateway '3014F711A0001F98A9A57FA6' not available, disabling support
2019-02-17 19:07:13.793 [INFO ] [ommunicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.41.11,address=PEQ1841062,rf=true,wired=false,hmip=true,cuxd=true,group=true]
2019-02-17 19:07:29.024 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'WIRED' on gateway '3014F711A0001F98A9A57FA6' not available, disabling support
2019-02-17 19:07:29.123 [INFO ] [ommunicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.41.11,address=PEQ1841062,rf=true,wired=false,hmip=true,cuxd=true,group=true]
2019-02-17 19:07:47.214 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'WIRED' on gateway '3014F711A0001F98A9A57FA6' not available, disabling support
2019-02-17 19:07:47.273 [INFO ] [ommunicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.41.11,address=PEQ1841062,rf=true,wired=false,hmip=true,cuxd=true,group=true]
2019-02-17 19:08:02.478 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'WIRED' on gateway '3014F711A0001F98A9A57FA6' not available, disabling support
2019-02-17 19:08:02.539 [INFO ] [ommunicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.41.11,address=PEQ1841062,rf=true,wired=false,hmip=true,cuxd=true,group=true]
2019-02-17 19:08:17.739 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'WIRED' on gateway '3014F711A0001F98A9A57FA6' not available, disabling support
2019-02-17 19:08:17.805 [INFO ] [ommunicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.41.11,address=PEQ1841062,rf=true,wired=false,hmip=true,cuxd=true,group=true]
2019-02-17 19:08:33.005 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'WIRED' on gateway '3014F711A0001F98A9A57FA6' not available, disabling support

Has anybody an idea what’s going wrong here?

Your openhab instance has a strange ip adress. Look at the dashboard ip. This is an automatic ip adress which is never useful.

Oops. That must have been changed by the openhab-cloud installation. I’m just going back to the last stable image…

I doubt that. The cause is something else.

You’re obviously right. I’ve set up the system upon the last stable version and added the Homematic Gateway (no Openhab Cloud). Again, everything worked fine. Log showed my regular ip addresses for starting the dashboard. But then - after a reboot - same procedure: Again those cumbersome ip-addresses and again all homematic things were offline.

And now it get’s funny: I still had all the unused things from my homematic bridge in the inbox. Just out of curiosity I added one of those things and kind of a miracle occured: The bridge and all devices went online. I’ve rebooted again and still everything worked. But the logfile still shows that unknown ip-addresses:

2019-02-17 23:52:37.562 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2019-02-17 23:52:37.572 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at

Something seems to be wrong with my installation.

I answer to myself for documentation purposes. The address 169.254… is a generic address, which is widely used in case, that no DHCP service is available to get the ip-address. My first thought was, that during the boot procedure openhab starts before the network connection has been established. I can’t verify that but after some trials I experienced, that:

  • after a reboot, Dashboard starts at a generic address, but
  • after a openhab2.service restart, Dashboard starts at the right address.

I still don’t know, whether this has anything to do with the issue reported above, but I find it interesting after Joachim Boedekker mentioned those ip addresses.