Homematic Bridge with HmIP only

I’ve installed openHAB 2.2 on my Synology NAS and can’t connect the Homematic Bridge to my Homematic CCU.
The auto discovery isn’t finding my CCU so I’ve added it manually.

018-05-04 12:43:55.524 [hingStatusInfoChangedEvent] - 'homematic:bridge:87540ef6' changed from UNINITIALIZED to INITIALIZING
2018-05-04 12:43:55.673 [hingStatusInfoChangedEvent] - 'homematic:bridge:87540ef6' changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): java.net.ConnectException: Connection refused

I wasn’t sure if it’s a openHAB issue so I’ve tried it with ioBroker:
Auto discover did find my CCU and it works as expected.

I’m running a OCCU in a docker container only with HmIP.

Any help would be much appreciated.

I guess the issue is that I’m using the HmIP Usb Stick which is only supporting Homematic IP.
Is it possible to use this binding without using the non IP protocol?


Have you checked the firewall setting in your OCCU to allow access from the right networks / IPs?

Yes, I’ve checked the trace log. The issue seems to be that the binding tries to connect to the RF port 2001 and won’t get a response cause I’m using the RF-USB stick which is only supporting HmIP (port 2010).

@Crazy could you share your setup. I’m also looking for a way to access my Homematic IP devices from a Synology disk station. Did you ever got this to work?

I am running into exactly the same problem - setup is Raspberrymatic (raspberry pi running OCCU) with RF-USB stick. I think your analysis is correct: the Openhab binding tries to reach rfd daemon at port 2001; if it fails it does not even try the HmIP port (2010) anymore - most probably because prior to the RF-USB stick existence there was no CCU (or equivalent solution based on OCCU) with HmIP only support.